KM Not Passing Modifier Keys to Microsoft Remote Desktop

  • I just started using Microsoft remote desktop (MRD) and I'm trying to get my first shortcut setup. The attached file shows that I created a separate group and tried to map ctrl-9 to ctrl-RightArrow.
  • Result: The macro only sends the RightArrow command. That is modifier key (ctrl) is being stripped as mentioned on this thread.
  • There is no other conflicting macro.
  • I'm running Big Sur , KM 6.4.8 and remote connecting to Windows 10.

I would really appreciate any help or suggestions.


Hey Don,

Search the forum for “Microsoft Remote Desktop”, and see if you get some clues:

Search results for 'Microsoft Remote Desktop' - Keyboard Maestro Discourse

Why are you running such an ancient version of Keyboard Maestro (6.4.8)?


Unfortunately, Keyboard Maestro can only simulate the keystrokes, how MRD handles them is beyond Keyboard Maestro’s ability to control.

That said, there was at some point a change in the API used to simulate keystrokes, and so it's possible the current version of Keyboard Maestro behaves differently (version 6 is a long time ago). But I don't know whether v6 was before or after the change in the API used.

Thanks for your response. I was hoping there was a setting in MRD or KM that would fix the problem.

I'm also concerned about upgrading KM as doing so may introduce other issues.

Hey Don,

While that's not impossible KM is remarkably stable between releases.

If you make a full backup of your user-files you can always revert to the older version if something untoward happens.

~/Library/Application Support/Keyboard Maestro/

Keyboard Maestro 6.4.8 is ancient at this point. Peter will soon release KM 10...