KM not working when sharing screen - what am I missing?

I am screen sharing a Mac-mini that has KM installed (Version 7.0.3). When I press keys that are supposed to activate a macro on the Mac-mini, the macros on the shared screen Mac-mini are not activated. Hence, I resort to clicking the application in the menu bar and choosing the macro from the list of macros (Trigger macro by name…).

I checked the keyboard settings on the screen shared Mac-mini and the keyboard appears to be the default keyboard (US).

Has anyone else experienced this?
Might the phenomena be related to the keyboard or keyboard settings on the Mac running screen sharing?

Thank you for any thoughts or experiences people might have!


There is def. some weirdness when using share screens and KM but I believe that the issue you are having has to do with either.
-Not having the actual share screen application selected when inputting the hot keys.
-System preferences–> Security and Privacy–> accessibility–> KM should be given ability to control your computer.

Hope this helps.

The Weirdness I am experiencing has to do with when being logged in on a separate account with share screens. ie. One account is being actively used by another user. I find that some of the functions like find image and find pixel seem to not function… This can be irritating but to be quite honest I have found work arounds. I am wondering if it has something to do with the the screen sharing process…



HI Oops,

Thank you very much for your suggestions! I appreciate you taking the time!

Unfortunately, neither is the case. I am definitely working in the shared screen application when I issue the KM macros. I also verified that the machine I am working on (as well as the shared screen machine) have security preferences set to allow KM to control the machine. I will continue to experiment and, if I find out what is responsible, will post it for all to view in case it is helpful to those experiencing a similar issue.


Hey Shawn,

Does your macro trigger include any Function keys (F1, F7, etc.)? And do you have a physical keyboard plugged in to the remote Mac Mini?

I ask this because I have found with my remote Mini setup that in order to set the Function keys to work as standard Function keys and not the Volume Control, etc., I had to plug in an actual keyboard to the Mini, go into System Preferences, Keyboard, and tick the checkbox to “Use all F1, F2, etc. keys as standard function keys…” Otherwise that option doesn’t even appear without a keyboard plugged in. However, once I have selected that and closed out of System Preferences, I can unplug the physical keyboard, and while the check box option for the function keys disappears from the keyboard tab in System Preferences, they still continue to work from then on as function keys and not Volume Control, brightness, etc.

That maybe doesn’t have anything to do with your particular situation, but I thought I’d throw it out there just in case.


You wouldn’t by chance have a Password manager installed that sometimes messes with KM…

Best of luck,


Dear BinaryTim and Oops_I-Broke_it,

Thank you both, very much for your additional comments and suggestions - both are appreciated!


> Does your macro trigger include any Function keys (F1, F7, etc.)?

No. I use mostly combinations of the standard keyboard and Ctrl, Alt, or option keys - on both the remote and local Macs

And do you have a physical keyboard plugged in to the remote Mac Mini?

Yes - both Macs have a physical keyboard attached to them. Your observations and experiments are quite interesting though!

There were two (2) ways I found around this. The first is to quit the KM
engine on the primary computer before using the trigger on the remote computer
, and the second was to use triggers on the remote computer that are
completely different than any I have on the primary computer.

I really appreciate all the background you provided! My local Mac is a MacPro running 10.10.5 and the remote Mac is a Mac-mini also running 10.10.5. Each uses KM 7.0.3. Your first workaround, putting KM on the local machine while using Screen Sharing makes perfect sense. The second workaround also makes sense, but has the disadvantage of using different key patterns for similar shortcuts - which is not what humans like to put to memory!

Great ideas none the less - thank you very much!!


You wouldn’t by chance have a Password manager installed that sometimes messes
with KM…

No - I do not use a Password manager. I could see how that might interfere…

Thank you both again! I’ll probably resort to quitting KM on the main machine or triggering KM macros by name using its menu item on the shared screen as my two workarounds.