KM works on MS for Mac 2011 but NOT with MS Word for Mac 2016?

Am I the only one who has macros that work on MS Word for Mac 2011 but don’t on MS Word for Mac 2016

I have a simple one that triggers " → DONE" in dark red font to signal a task is complete.

The exact same macro triggers different results depending on the MS Word version.

Case 1 (Correct) . In MS Word for Mac 2011, the result is the following with with “DONE” in dark red font as expected.

“Task → DONE”

Cast 2 (Error) . In MS Word for Mac 2016, the result is the following with "Task → " in dark red font (Not “DONE”, on two rows (“not one”) & “DONE” still in black (“not dark red”). Backwards day?

“Task →

The only change is the MS word version as I ran them side by side just now.

Anyone else seeing this?

Many thanks for anyone’s help

You can get better help quicker if you will post your macro.


Here it goes.
Note, the ".>" step triggers the arrow "→" from TextExpander.
Thank you

Keyboard Maestro “→ DONE (dark red)” Macro

→ DONE (dark red).kmmacros (4.5 KB)

Thanks for posting your macro.
Your macro seems overly complicated to me.

You might try this.
It works in Word 2011, but I don't have Word 2016.
It should work in any app that supports rich text, including Word 2016.

##Macro Library   @Word Paste Rich Text Into Word

<a class="attachment" href="/uploads/default/original/2X/3/3dc39c85546ce293b7f1d39ea675e4704ab2c77b.kmmacros">@Word Paste Rich Text Into Word.kmmacros</a> (2.6 KB)
**Note: This Macro was uploaded in a DISABLED state. You must enable before it can be triggered.**



Enter the text, and set the format, in the first Action.
To set the format, either goto Edit > Format, or press ⌘T to show the Font selection dialog.


<img src="/uploads/default/original/2X/3/3cd4e59a241c168c677d9bba4711efddc5782dab.png" width="474" height="406">

I have the (near) current version of Word (Office 365) which claims to be 15.34, 2017, and your (@JMichaelTX's) macro worked fine, pasting the styled text. I embellished it a little to test further, and it pasted all the details:

Word 2017 didn't handle embedded images, but not much does.

JMichaelTX & peternlewis,

Thank you for the help.

I am still a novice user so that much simpler macro is much appreciated, which I will use

Unfortunately, in Word for Mac 2016 (from Microsoft 365) version 15.36, this macro returns the entire string "Test → DONE”

  • In 8.5 font (rather than 11 as created in the style section &
  • The entire string (rather than just the “ → DONE”) in dark red font

It works perfectly in Word for Mac 2011.

This suggest either something is different (or I am missing some setting) in Word for Mac 2016.

I may just need to use Word for Mac 2011 unless I can figure this out.

Did you add the word "Test" to my macro, because my macro has ONLY → DONE".
If you did, then you will probably need to format the word "Test" in the KM Action.

Any time you paste into Word, it gives you a little popup button, that has "Match Destination format", and "Keep Source format". Are you getting that in Word 2016? If not, have the set the Word 2016 preferences to always match destination format?

I'm curious, is there any material difference between Word 2016 and Word 2011?
I have not been any to find any in my research, so for now, I'm sticking with Office 2011.

I didn’t add “TEST”. I intended this macro to put " → DONE" after a task like “TEST” (or any words describing a task) was " → DONE", but in MS Word for Mac 2016 the macro is grabbing the whole string & formatting is as described below (wrong font size & color)

In that dialogue box When I choose
-“Keep Source Formatting”, it returns the wrong font size & color as described above
-“Match Destination Formatting,” it returns the original formatting (i.e. no font color but the right font size)
-“Keep Text Only,” it returns the original formatting (i.e. no font color but the right font size)

I am concluding this is too much work to use MS Word 2016, so I agree going back to MS Word 2011 is the best solution unless I stumble across the answer. Now to reset MS Word 2011 as the default!

Thanks for the attention & follow up.

OK, I have a solution.

Firstly, going back to your original macro, the Clear Typed String Buffer and Cancel All Macros are unnecessary. There is almost never a need to use Clear Typed String Buffer, it exists for very unusual situations, and you can simply let your macro finish, there is no need to cancel all macros at that point.

Next, there is no need to use .> to use Text Expander to expand the →, just have Keyboard Maestro insert the → directly.

But even if you just paste in:

Word 2017 does weird things end applies the red to the existing words on the line, which is bizarre.

However, I did come up with a solution. First, in Word, create an entry like you want

entry → (RED)DONE(/RED)

Select the arrow and the DONE and copy it to the system clipboard.

In Keyboard Maestro, open the Keyboard Maestro Preferences, switch to the Clipboards pane, and click the + button to add a new Named Clipboard. It will be pre-filled with the current clipboard that you just copied from Word.

Now your macro becomes simple Paste from Named Clipboard, and select the named clipboard you just created, probably named "→ DONE".

That's it.

I will try over the next few days & get back. Regards, Todd