Logic Pro X - Can't input text in text boxes

Dear all,

  • KB Meastro engine running (latest version)
  • Logic Pro X opened and in foreground.
    I experience the issue that i can’t input text in textboxes in Logic (for instance, to name a Marker).
    If the text contains letters that i have assigned in KM to actions, it appears that KM steals those letters, trying to execute the commands that are tied to that letters.Thus, i can’t input the text correctly in Logic.

Is there some remedy to this issue ?
Warm Regards.

I don’t have Logic, so I can only guess from your description at what might be going wrong, but it sounds like the macro triggers you have currently are identical to shortcuts for commands in Logic. KM is designed to let you make your own shortcuts that can replace the defaults of a given app, so the only way to ensure that KM doesn’t interfere with your Logic commands is to ensure that the interfering macros are not active when using Logic. If the macros interfering aren’t needed in Logic, you can just make a new macro group that excludes Logic and place the macros there. If you do want to be able to use these macros in Logic but also not have them interfere, you either need to give them new trigger shortcuts that don’t overlap Logic’s commands, or change the way you trigger them altogether, perhaps via the status menu or a palette.

I want to thank you for helping me.

I justed tested again:

  • i assigned the key V to a native Action in Logic. (Paste).
  • i then assigned that same key V to a Macro in KM.
  • In Logic, i opened a window in which i have to type in text (the Marker List window).
  • As soon as i use the key V for text typing, i get an error in Logic , that there is nothing to Paste.
    So what’s happening is that KM takes priority over the V and executes the macro that is bind to it, altough i am typing the V in a textbox.
    So interfering keycommands between KM and Logic is not the issue, it’s solely that apparantly, KM can’t “see” that i am in a text typing area in Logic and am trying to type text.

You’re welcome, and you’re correct. Unless there is some sort of condition that’s only active when typing in a Logic text box, such as a menu item that’s only enabled in such cases, or the name of the front window changes to something different, I’m afraid there isn’t much that KM can do to see that you’re typing in a box as opposed to using the keyboard in a text box. Still, if you’re determined to use a standard “V” key press to paste instead of Command-V, you might take a look through the If Then Else conditions page on the wiki to see if there’s something you could use.

Thx again for helping me gglick.
That sounds abit of a big bummer to me then.
I can’t imagine only Logic suffers from this issue.
I mean, alot of other software that you wanna control with KM will have text input boxes, where you just wanna
put in some text without KM thinking you wanna trigger Macro’s.

If only there was maybe a configurable shortcut for temporarily disabling the KM Engine, then that could be a workaround for me.

I am gonna lookup the “if then else conditions page” , thx for this tip !

No problem. There is indeed an action to enable, disable, and toggle certain macros and macro groups that you could use to turn off the macros you don’t want to use at a given time: https://wiki.keyboardmaestro.com/action/Set_Macro_or_Group_Enable

But since that would add an extra step every time you want to use or not use your macros, I would honestly just suggest using a different trigger that wouldn’t interfere with standard typing, such as Ctrl-V, or even a typed trigger that doesn’t require modifiers like Command or Control, such as typing “V” twice or three times instead of only once. KM has a lot of depth, so while it may not be immediately clear how to set up macros that make your Mac work the way you want it to work without any side effects, I can promise you that you can get very close once you get past the initial learning curve.

Excellent idea regarding the Toggle Macro Group for Logic on/off.
Works great and will certainly do for me as a solution !
Thank you !

1 Like