Logitech K750 and CMD-TAB (And CMD-`) Hotkey Problems

I just changed out my Apple Bluetooth keyboard for a Logitech K750 Solar keyboard and everything is in order except for one KM problem:

I have the App Switcher set to the CMD-TAB hotkey and the window switcher set to the CMD-` hotkey and, with the new keyboard, they only kind of work: they work as toggles rather than letting me continue to press the hotkey combo to cycle through the open apps and window.

Where I used to be able to hold down the CMD key and hit TAB TAB TAB to select amongst applications, now it always acts as if I just hot CMD-TAB and released.

Note: I tried restarting KM, restarting my Mac, and then restarting the Mac and then KM. No joy. I am running a MacBook Pro, OSX 10.11.3

The normal behaviour for the action is to keep the display window up until the modifiers change. It’s hard to know for sure, but it sounds like the Logitech keyboard is releasing the Command key when you’re keeping it pressed. You could try the system “Show Keyboard Viewer” and see if you can see anything. You could try using a different modifier to see how that behaves.

Using the Keyboard Viewer, it appears that CTRL, OPT and CMD all act the same way…they are releasing even though I’m not physically releasing them. This means either dumping the KM switchers, which I like, or replacing the keyboard.

Unless you can think of anything else that might help?

You can use a trigger without any modifiers and then the window will stay up until you explicitly select something or escape/cancel it. But otherwise, no, if the modifiers appear to lift, then that’s going to be a problem.

Hi Chris. Maybe there is something wrong with your Logitech drivers.
I also have the K750, and the Keyboard Viewer shows those keys are down as long as I physically hold them down.

I don't use the KM switcher, but when I use the Mac switcher (CMD-TAB), it works perfectly. The app list shows as long as I hold down the CMD key after the first CMD-TAB.

I'm running KM 7.0.3 on Yosemite (10.10.5).

Can you try enabling the KM switcher, mapped to CMD-TAB and see if you can replicate the problem? Because the system switcher indeed works the way it is supposed to but KM’s does not. Perhaps this is a KM problem after all.

I'm not on that Mac right now, but I'll try to test that later today.

However, note that my keyboard shows differently using the KB viewer:

Right…what I discovered is that this problem only occurs when attempting to use the modifiers as part of a KM macro. The modifiers stay pressed down when I physically hold them when they aren’t part of a KM macro, but if I enable a hotkey like CMD-TAB, then it acts as I described.

OK, just did a test using the KM App Switcher.
It works find for me using the K750 keyboard.

  • Switcher remains visible as long as I hold down CMD key
  • Keyboard Viewer shows key down as long as I physically hold it down.

Thanks. Just to verify, you tested with the CMD-TAB hotkey?

I nuked all Logitech software and reinstalled…still having the problem that the Switcher appear and disappears as soon as I hit CMD-TAB, effectively toggling between the two most recent windows, though now the CMD is flashing and reappearing as solid in the keyboard viewer even though I’m not releasing it! Since this doesn’t affect the system switcher, this is some problematic interaction with QM.

Any thoughts on how I might further troubleshoot?

EDIT: Ah, I also see you are Yosemite and I am Capitan. That might well be part of the problem.


Thanks for taking the time. If you ever upgrade to Capitan, I’ll be interested to see if the problem crops up!

I'll let you know when I upgrade, but will probably be at least 6 months. I'm still waiting for all the apps I rely on to be fully compatible with El Capitan.

I’ve been having this issue too, on my iMac running El Cap but not with the MacBook Air, (both El Cap) and I just found this thread. The difference is the K750. For the heck of it, I moved the logitech receiver to my MacBook Air and wasn’t able to replicate the problem. So now I have my iMac in safe boot mode, and have launched KM. The Application Switcher works perfectly. So now to go hunt down whatever piece of logitech junk ware causes this problem… I will report back.

Rebooted in normal mode, uninstalled Logitech Control Center (using the uninstaller in /Applications/Utilities). The problem is gone.



Sorry for the delayed reply. I upgraded to El Capitan months ago, and I am NOT having any issues with the Logitech K750. This is on my MBP-15R.

I' now running Keyboard Maestro 7.3.1 (7.3.1) on macOS 10.11.4.

Had the same issue with the CMD key down. Solved with the LCC uninstaller and not just removing preference pane item. Thanks!

1 Like

Same here - same problem with the switcher with K750 on El Capitan v10.11.6. I uninstalled LCC and the problem went away. Thanks for sharing the tips! I’m still not completely sold on this keyboard but trying.

Strangely, the Application Switcher suddenly stopped working this morning. I uninstalled LCC and it immediately works again. I did not even need to reboot.


I really like Logitech hardware, but I've had so many problems with their software I won't use it.