Lp -o command to set print quality for epson inkjet ET-7750

Going back to the well of Information after having spent all day trying to come up with the right command in my mac script to print a purge document from KM. I have it where it prints but I can't find the "Print Quality" command to set photo or high quality photo. This is what I get when I query the printer for cups lp commands: EPIJ_Qual/Print Quality: 301 302 303 308 304 *305 307
it's worse than greek to me because no matter what I put it doesn't change the printed output of the document.
This is what is working:
lp -o print-quality=5 -o landscape -o media=letter -d EPSON_ET-7750_Series ~/Documents/PrinterTestFiles/"Epson ET-7750"/ET7750PRINTPURGE.pdf
The "print-quality=5" is wrong but I've tried so many other combo's like quality:Photo, print-quality=photo or best.
Does anyone have a clue on what the actual command might be?
Why am I doing this? For some reason if my Epson ET-7750 doesn't print a doc every couple days I have to run a cleaning cycle on it.. this will take care of that!
thanks for your time and assistance,

The output you included suggests that the print quality argument should be 305, or 302, etc. But it might be that 3 is the "main" quality, eg "Photo", while 05 is a refinement within that.

Change the settings manually, see what the query gives you. The format is

Name_Of_Option: *setting1 setting2 setting3

...and the current setting is the one preceded by the *.

I think I've tried that but I'll try it again. I even set the default to high quality photo in CUPS and that didn't seem to make a difference. This used to work until I upgraded to Sonoma.
Thanks for your suggerstion, I'll let you know.

UPDATE: No Change. I guess I'll keep digging.. perhaps an Epson forum would be the best place to check!

Try -o "EPIJ_Qual=307" to set quality to "Best Quality". The options are numbered in the CUPS list order -- for completeness:

Fast Economy   301
Economy        302
Normal         303
Draft          304
Fine           305
Quality        306
Best Quality   307

Tested using lpadmin and the CUPS page, so here's hoping. I haven't tested the rest of your command, but I'm assuming that's right and it's only the quality your having problems with.

no difference between 301 and 307. GRRRRR! I've posted in the epson forum. I know I had it working before so thats whats driving me crazy. I"m going to try some variations on what you posted.

thanks for your time and assistance,

No difference in the output? That might be a driver issue.

You could try setting the CUPS default quality, then send the job, then reset the defaults. Use

lpadmin -p Epson -o "EPIJ_Qual=307"

...replacing "Epson" with your CUPS printer name and "307" with the setting you want.

Also, try manually setting the default quality via CUPS and see if that does anything -- then you'll know where the problem is.

I actually went into the CUPS web admin page and set the default to Super Ultra Premium High Quality or whatever the best is. If I manually select the best setting in a program and print the page, it works great. It may not be that big a deal, it may be I'm wrapped around the axle for no reason or real gain so thanks for your insight and guidance.. if by some chance this dog does get the bone, I'll let you know what worked in a reply in this post.

Are you saying that changing via CUPS makes no difference to the output?

It may be that you have to match paper type to quality as well -- I notice in the "standard" print dialog that not all qualities are available for all types of paper. If we use CUPS to select something that's outside what the normal dialog will allow, perhaps the printer barfs and just uses its internal default quality.

Yes, I changed it in CUPS web admin page to set the default and it doesn't make any difference. One of my faults is when something won't work like I think it should, I can't let it go. 21 yrs as a USAF Aircraft Crew Chief and 10 yrs at GoDaddy hosting support. GOTTA FIX STUFF!