Macro fails - but not

After updating to KM v.7 i experience problems with the attached macro and I don't know why.

Actually the macro runs okay. But every time it's triggered, Keyboard Maestro shows a notification that says "Action failed". Nothing appears to be failing though.

Two questions:

  • How do I fix the problem?
  • Is there an error log where I can see what the problem might be?

Thanks a lot!

My suggestion would be that the 'Create New Folder' action is throwing up an error because the folder already exists?

I tried a simple version and this was the result, I'm assuming SSID is something to do with a WiFi location but at any rate it doesn't look like it changes, so if there were two or more files of the same type then I would expect an error.

My version did show a reasonable error message in the notification centre though.

There are two log files in ~/Library/Logs/Keyboard Maestro/ which might help.

Quick answer!

I think you might be right about that. When opening the Notifications panel I realized that I get the exact same error message.

How do I fix this then? Before updating I would just move the files without saying anything if the folder was already there…

Actually I just found that you can ask KM7 not to notify you when the specific action fails. Thats sort of solves the problem…

Yes, but it will replace files that have the same name, if that isn't a problem then you're done.

Otherwise you need to check. This is a simple example with hardcoded values. Where I have used A.A and AAA those are your variables, the one in the 'Rename' section adds the time to the filename so that should be unique.

1 Like

Thanks a lot for the very quick answer.

It makes perfectly sense!

No problem, the 2nd version is better, uses the time to create a unique(ish) filename, unless you get two copies in one second it will work fine.

just started with KM and I am VERY impressed with it, replacing QuicKeys which hasn’t had an update in years!!