Macro fails - unable to find target menu item (Mojave)

When trying to use a simple macro (which worked in High Sierra) that pops up the "Tags…" editor in Finder, I get a failure to find the target menu item...

So I tried to rebuild the command by dragging "Select or Show a Menu Item" to the execution list, and using the UI pull downs to navigate to "File" then item "Tags…" - it's not in the list.

What is there (in the list) is quite odd - there are duplicates (for Compress), a triplicate of Eject - but no "Tags…"

To be fair, I had a Finder keyboard shortcut - and that stopped working too...


I'm not sure if there is a solution for Mojave at this time, but this topic appears to be about the same issue:

Having the same issue suddenly this AM. Cannot find the submenus when setting up the action in KM. Instead, I get a long list of all menu items, with submenus below the parent menu, with no nesting arrow next to the parent folder.

Not sure if this is helpful, but I fixed my issue in the strangest and simplest way:

In Mail, I have been moving messages to nested folders via KM. But as of this morning, it wasn't working, and I was getting the 'Select menu item failed to find target menu item' error.

When I checked the 'Select Menu Item' action in KM, I can see 'Mail'->'Message'->'Move To' and my folders, but some of the folders were no longer nested, and if I selected one of those folders, the macro would give me the error.

It turns out, that if in Mail the folder in the left column (the Mailbox) was expanded, it would show up in KM as a list of parent and child menus, no nesting, and would not work. I merely had to close all the parent folders so that the subfolders were hidden, and KM works as expected.

I don't know if this is applicable to your issue, but I hope it is helpful.

I had the same issue with Visual Studio Code. Just upgraded to Mojave.
Restarted the computer - the macro works.

However, the drop down menu in the right side of the action does not populate for Visual Studio Code as it does for all the other applications. Used to work as far as I can remember. Something is amiss.

Thank you @sawmri.