Macro Group Activation/Deactivation Not Working in KM 8.2.4

Updated Keyboard Maestro to the latest version. Still not working.


Nothing is happening. The macro group doesn't deactivate or activates.

I checked macro group and macro are enabled.

By the way, what the "Display toggle" option do?

Hey @politicus,

It was working before? And is now not working after the upgrade?

What version of the macOS are you using?



I can't tell wether it was working before as I only tested this macro with this Keyboard Maestro version.

Tested using Mac OS X 10.12.6.

Hey @politicus,

Make sure your test macro is Global.

Then switch to Brave.

Then hit your keyboard shortcut.

If it doesn't work then try changing the keyboard shortcut to something simple like F1.

The “Display toggle” checkbox enables a pop-up window that tells you the enabled/disabled status of the group – this is advantageous when changing the group status has no other visual cue of what happened.


@ccstone Thank you. Did all these and still not working.

I moved your question and replies to a new topic since this issue was reported and confirmed fixed in Keyboard Maestro 8.0.2, in Sept 2017.