Macro stopped working in macOS Sierra

Hi All,

I am not sure what the problem is here and cant seem to find an answer here. I have been using a macro that if I am on a keynote or a pages document and I want to open it in 09 version of pages I would hold down control shift then click on the document. That would then open it in the older version of keynote or pages.

To answer the question that you may have on why do you want to use the older version of pages or keynote is because with my job we have to. Though I still have the latest keynote and pages installed as well since we also use them.

Image of the macro that is not working>

Have you tried to relaunch the Finder?

I’m also experiencing a problem with KM Finder macros on Sierra: Sometimes my Finder macro group doesn’t get enabled even though Finder is frontmost. (The Finder macros don’t appear in the global palette.)

This is often accompanied by a very noticeable Finder lag, so I guess it’s a Sierra problem. Relaunching the Finder seems to help in these cases.

Sorry, I don’t have any suggestions to solve your immediate problem.

But I do have one question, and possible suggestion. I don’t fully understand your use case, but if the reason you are using two different versions of Pages is file format, can you not “Save As” to the older format using the latest version of Pages?

Actually I do have one suggestion: Have you tried using AppleScript to open the version of Pages (or Keynote) that you want, and then tell it to open the document?

Yes I have tried to restart Finder and the computer. No change.

No I have not tried AppleScript yet.

Yes I could save as the older version but the content wont look the same when I open it in the newer version sometimes. It is easier to use the older version and save it with the older version to make sure the content is intact.