Macro to open iPhone sync settings

More often than not when I connect my iPhone to my laptop, it doesn't show in the sidebar. So one workaround that works all the time is to open the Music app, click iPhone in the sidebar and then click the Sync Settings button.

Is there a way to create a macro that opens the iPhone window directly without using this workaround?

Are you looking for a macro to do what you're doing manually, or are you wondering if there's another solution?


Wondering if there's a way to access that window without doing it manually or having KM do it for me, meaning, I don't want KM to open Music > iPhone > Sync Settings (even though I could do that to save time, but the goal is to access that window without any "band-aids").

I think I'm a bit confused, the iPhone now shows in Finder when you connect. Have you looked for it there?

If it's not showing directly in Finder, then there's something going on that's causing the problem. And because iOS devices aren't "real" devices to macOS, you can't directly access them via Terminal, so there's no Terminal solution like using a disk mount command, because the device doesn't exist as something you can reach from Terminal.

If the only way you can make it show is by launching Music, then that seems what you'll have to do—or debut the issue. (Do you use any Finder extensions? Have you tried connecting from a new user account to see what happens there? etc....)


Yes, that's why I said "it doesn't show in the sidebar".
Sometimes it does, sometimes it doesn't. When I use the Music app workaround I'm always able to access it, but not via Finder.

What's weird is that, as I'm writing this message, I can see it in the sidebar, but... it's not even connected via USB. And sometimes when it's connected via USB, it's not visible.
Go figure...

I haven't yet. But since this is not always an issue, trying another account may not be the best way to see if the issue is the account. Maybe it will work there when I test it, but that doesn't mean it will always work. The same way it sometimes works in my main account.

I will keep using the workaround when I can't see it. No big deal. At least I have this workaround. It was driving me crazy before I found it.

Do you have wireless sync enabled? It sounds like it?


I'm here to ask the "is it plugged in question"... but..

Bullets two and three:

  • Make sure that the device is unlocked and the Home Screen is visible.
  • Check that Finder settings are set to show your device in the sidebar. See the instructions below.