Macro to switch ScanSnap profile?

Does anyone have a KM macro that can enable specific ScanSnap profiles? When scanning I use 2 main profiles that I often switch between and it would be quicker if I could use a keyboard shortcut to do this.

1 Like

Could you supply a screenshot of app and do you know if you can use tab to
get to the setting, where it is?

Use the Execute Shell Script action, and:

defaults write “Settings Index” -int n

where “n” is the index of the profile (starting at 0, then 1, etc.).

If you play with the settings, you can see how this file (in ~/Library/Preferences) changes with various options (simplex, duplex, scan both sides, color, etc.) and build macros to change them yourself.

It’s worth doing, since the existing interface, in my opinion, is clumsy.


And for what it's worth, here is my macro.

ScanSnap Profile.kmmacros (28.8 KB)


For what it’s worth? It’s brilliant! Is there a way to also add the option of adjusting the image quality? For example to choose from the ScanSnap image quality options of normal, better, best, excellent?


1 Like

Here’s what I did to figure out which entry to set using defaults write

I copied ~/Library/Preferences/ to my desktop. I then entered ScanSnap manager and changed the resolution from auto to excellent.

I used BBEdit’s find differences to compare the two files and found that the entry “Resolutions” changed from 5 to 4. I changed the setting using the GUI to “Normal” and then “Resolutions” became 1.

You can modify the script accordingly, using the existing option selectors as a template, and use shell command:

defaults write “Resolutions” -int n

where “n” is the appropriate integer value to correspond to the textual options.

Thanks. I really appreciate it. I’ve tried your suggestion. Although ‘Resolutions’ now appears as an option when triggering the macro, the choice i make has no effect. The other options still work fine. I realise this will be my error somewhere as I’m still very new to KM.

Post the macro…

Here it is: ScanSnap Profile copy.kmmacros (36.4 KB)

The entry you need to change with the shell script command is “Resolutions”. You’re trying to change “Resolution”.

This is the amended version. Initially it was choosing something from Resolutions, but not the correct choices I'd made. Then I tinkeered with it in an attempt to fix it and it's not working again. ScanSnap Profile copy2.kmmacros (37.6 KB)

You were missing an "if" for one of the cases, and your integer indices for the defaults write didn't correctly correspond to the values you wanted to set. This should work.

This does remind me, a "case" statement would be nice for the next update.

ScanSnap Profile.kmmacros (38.8 KB)

Following this at work so can’t check but…

Do the changes take effect immediately? No need to force ScanSnap to reload

Thanks for all of the tips guys!

They take effect immediately.

It works perfectly now. Thanks very much.

This doesn’t work for me in 10.10 using ScanSnap v6.3. I cannot use the individual settings (Resolution, Single/Duples, and the like) in “non-Quick Menu” mode, which is where one can use profiles.

When in Quick Menu mode, the scanning process is interrupted by the appearance of the Quick Menu, which I do not want. Thus, I am limited to using profiles, and not being able to select individual scanning characteristics, such as Resolution, Single/Duplex and the like.

Does anyone else have this behavior? Is there a work-around?

Digging up an old thread here…

I want to switch the ScanSnap profile as the OP did

I am trying this out with a terminal command right now, I am pretty sure I am writing and reading the correct setting. The read value changes when I change it via the ScanSnap menu…

But it doesn’t have effect on the active profile though. The ScanSnap menu doesn’t update and when I scan it’s still the old profile.

ScanSnap manager can be running through all of this, right?

Anyone else had this?


See if this will help:
SwitchToProfile – GitHub Gist

I continue to use the macro almost daily and it still works for me.

Had to swap out the name of the menu and that of the apply button to German, but other than that it works great. At about a second of execution time it is fast enough as well for now

Won’t look for the issue with the other approach

Thanks! :slight_smile: