MACRO: Variable Inspector Prompt and Dictionary Editor v3.2

I didn't realise that so I've just tested it and yes, that works - but if I move the prompt from, say, display 1 to display 2 it will then always appear on display 2, even if the frontmost (active) window is on display 1.

What I want is for the prompt to automatically appear on display 1 or 2 depending on where the frontmost (active) window is which is what my extra action achieves.

I hope that makes sense!

Ah yes, that does make sense, and the way you accomplished it looks perfect.

Can you delete your "45" macro, and install this one, and verify everything works correctly when you resize with window? Thanks.

45)[VIP] Setup Variable Inspector Prompt - Advanced (Subroutine) (74.3 KB)

Yep - that's all working perfectly now.

Perfect, thanks. I'll update the first post, calling it "v3.0.1", but it's the same as what you have now, so you don't need to download it.

1 Like

Cheers, Dan, thanks.

1 Like

@DanThomas, I've download 3.01. THANK YOU—It's incredible.

Coupling Variable Inspector Prompt and Dictionary Editor with Favorite Actions and Macros makes is so much quicker and easier to create and debug macros. Every macro author needs these two tools!


Hi Dan,
When I use the Copy Variable(s) Contents button, I get an error:

undefined is not an object (evaluating 'navigator.clipboard.writeText')
in btnCopyVariablesClicked at 4858:24

Stack Trace:
onclick at 6931:24

Using v3.0.1

Dude, you gotta upgrade your OS. :slightly_smiling_face:

If that one fails, then so will the other Copy button, and possibly something else. I can fix it, though.

Delete the "45" macro again, and unzip and install these macros:

Clipboard (75.1 KB)

Let me know how it works for you.

Well, show me a new technology iMac with a big screen and I'll be there :crossed_fingers:

It doesn't - I get the exact same error.

Sorry, I forgot to put the updated HTML in the macro. Delete 45 again and import this:

45)[VIP] Setup Variable Inspector Prompt - Advanced (Subroutine) (74.5 KB)

Make sure you still have 56 installed.

1 Like

That seems to have fixed it, Dan. Thanks again for accommodating my obsolete OS :smiley:

1 Like

No worries. I'm actually thrilled you're helping!

1 Like

Just uploaded version 3.1. Hopefully this will be it for the updates. :crossed_fingers:

As I say in the version notes, if you have v3.0 or v3.0.1 and you're not on Mojave, you don't really need version 3.1, except that it consolidates some internal macros into one, so it's a little "cleaner".


I thought I'd make use of the "cleaner" 3.1 but I'm feeling a bit awkward now because the function to copy a variable's contents is not working anymore. When I click the copy contents button, nothing is actually copied to the clipboard.

That sounds strange. The macro 55)[VIP] Internal Inspector Tasks should get called when you click on the button, and the section that says "copyToClipboard" should happen. Can you stick something in there to verify that the macro is being called?


Make sure the group and the macros are enabled.

1 Like

That was it - the macros were enabled but the group wasn't. With the group enabled the copy function now works.

Thanks again!


This seems familiar :sweat_smile:


I've recommended looking in the forum/wiki for solutions to problems so many times I knew it would come round to bite me in the a$$ one day. LMAO.

1 Like