Macros don't work anymore after upgrade to Yosemite

I'm sorry to inform you that many of my great macros for CafeTran currently don't work. This morning I took the plunge and upgraded from Mavericks to Yosemite.

CafeTran is a Java translations editor. All macros have worked fine under Mavericks. Now all macros that should result in a case change (uppercase > lowercase etc.) don't work anymore.

A macro that duplicates a string ('wagen') still works.

Thought I could upload a movie here ...

Okay, then I'll insert a YT video and a Dropbox link:

A screencast:

An example macro:

After running the macro, if you switch to another app and paste, do you get the right result (ie, the uppercased text)?

If so, then you are basically back to figuring out either timing or clipboard caching as the problem.

Your macro already has a hack designed to try to work around clipboard caching by activating Keyboard Maestro Engine and then going back to CafeTran. Try changing that to activate the Finder, and/or try adding a pause before or after that.

If even that does not work, then you may have to try simulating a click in the menu to get CafeTran to notice the clipboard change, and if even that doesn’t work to get it to notice, then I really don’t know what more you can do.

Well, I suppose instead of pasting the clipboard you could type the clipboard:

Insert Text by Typing %CurrentClipboard%

its possible that would work, presuming you are not copying overly large amounts of text.

Thanks for the quick reply Peter. I will test your suggestions. I have already noticed that the problem has to do with inserting the modified text into the target sentence pane (visible below the dialogue box, in the video): I have another macro that takes the content of the source segment and the target segment panes, changes case of the content of the target segment pane to lowercase and writes the term pair to a text file (my Active Glossary): this works fine. So case change DOES work. It’s the putting the result back in the target segment pane part that doesn’t work (currently).

Thanks again!

I’ll test and report back.

Thanks for the great help, Peter!

'Issue' is solved now:

(Wow even dragging of screenshots is possible.)