Menu Item Unresponsive in Scrivener Macro

Catalina 10.15.7
KBM 9.2


I think that it's not necessary to know / use Scrivener to answer my question. Basically my macro does not trigger a menu item.

I want to be able to set Scrivener to Hide Page View.

The logic:

If the menu shows View ➤ Text Editing ➤ Hide Page VIew, then it means that it is currently in Show Page View and the macro should trigger Hide Page view

If the menu shows View ➤ Text Editing ➤ Show Page View, it means that Scrivener is in Hide Page View and all is fine ie do nothing.

I have to do this for many menu items. If I get it to work with Hide Page View, I can easily write the other macros.

What I tried : when a menu item exists, is enabled, etc Nothing works.

Thank you very much.

Scrivener hide page view KBM Forum question.kmmacros (3.0 KB)

1 Like

You seem to be using an uppercase EYE or a lowecase L in your command. Try fixing that first. It should be a lowercase EYE.

What you are doing is doable. I've done it in Keynote.

1 Like

hello @Sleepy

My apologies for the mistake which I corrected.

Unfortunately the problem persists. This time, I reviewed the macro 20 times letter by letter. I also checked that there are no extra blank spaces at the end of menu items

As I mentioned previously, it is more than a question of one macro. I am configuring a special Scrivener project and there are many similar commands.

Thank you very much

Scrivener hide page view KBM Forum question.kmmacros (3.3 KB)

Let me go check my Keynote code. I've done this before.

HEY, I see a difference between your method and mine. You are using "with path" while I use "with this name". Mine works, so try doing that.

I was guessing that it was case sensitive, but I may have been wrong about that.

P.S. I'm going to be AFK for about 12 hours now, I think.

1 Like

Unfortunately, it still does not work after trying all the options in the drop down list, including path, name, contains, etc

I also tried to separate and test the 2 actions which are grouped in the macro, as below

  • The keyboard shortcut alone (3) typed by me in Scrivener works fine.
  • To exclude 2, I combined 1 and 3 and it does not work, meaning that 1 does not work.
  • I also tried using 2 alone and it does not work (the menu does not open up with Hide Page View highlighted as one would expect
  • I also tried to modify View > Text Editing >» Hide Page View and use only Hide Page View, and it did not work

I totally understand that you are busy and wish you a nice day. Thanks again

Hey @ronald,

Yes – testing IS required to solve this problem.

As @Sleepy observed you had misspelled the menu-path you were testing, but that wasn't the only problem.

It seems Scrivener is dynamically creating some element in the View > Text Editing menu, so in order to do what you want you have to open it before testing for the final target.

When using menu-paths always test to see if they work by using a notification or other method before moving forward.

Feel free to complain to the Scrivener developer as well.


Scrivener Hide Page View v1.00.kmmacros (7.7 KB)
Keyboard Maestro Export


Works perfectly. Thank you very much Chris for the macro and all the testing. It is greatly appreciated.
I am sorry that you seem to feel that I was not testing enough before posting. I did spend 2 days trying to troubleshoot the macro.
As for the typo in the initial post, yes it is inexcusable. I apologize again to both @Sleepy and to you.

Nonsense – mistakes are unavoidable for humans...

But – there are methods to mitigate their number and severity.

For instance – you could use the Select or Show a Menu Item action to extract the menu items of the menu-path you are trying to create.



Thank you very much. In the wiki, the following comment is useful
If you leave the menu item blank, Keyboard Maestro will show you the menu and leave it displayed so that you can then select the desired menu item manually.

I'm not sure how long it would have taken me to find cc's solution. That was great work.

Your apology was accepted, but I don't think it was necessary. If you forgive us when we are overly-testy we will forgive you when you are underly-testing. :slight_smile:

1 Like

great comment ! thank you so much for your kindness