Modifier Keys on a Koolertron 23 Keypad Are Invisible?

I'm trying to get a Koolertron 23 key macro keypad to trigger KM macros.

I have programmed keys to send things like Shift-Control-A, and Karabiner Elements tells me that it is working – but KM only recognizes the “A”. Tthe modifiers are ignored.

I tried the USB device key trigger, but that didn't work..


Only recognises it when? When setting a hot key in a trigger?

To probably send a Shift-Control-A to the system, the device has to simulate the full sequence:

  • Shift down
  • Control down (with Shift modifiers)
  • A down (with Shift&Control modifiers)
  • A up (with Shift&Control modifiers)
  • Control up (with Shift modifiers)
  • Shift up

Keyboard Maestro gets told the key that is pressed and the modifiers by the system, so if it is not getting the correct value it is because the system doesn't think that Shift-Control-A is the event that is being generated. Unfortunately, without access to the device (and probably even with access to the device) I can't offer much more of a suggestion.


I appreciate you taking the time to explain this, it is quite illuminating. Nevertheless, I have solved my problem by using typed string triggers, with which Keyboard Maestro seems comfortable. I think the recognition of these codes by Karabiner Elements teased me into assuming that KM would/should see them too. I still don't really understand why that is the case, but will reread and reflect on your generous explanation for now. thank you