Mouse control in Mojave


Has anyone else tried manipulating the mouse cursor in Mojave? I'm running Mojave 10.14 Beta (18A326h) and KM 8.2.2.

I just tried creating a simple keystroke triggered macro that moves the mouse cursor to a specific location on the screen and nothing happens. I also have a number of existing mouse macros that stopped working after updating to Mojave. My other non-mouse related macros are working fine.


Seems to work fine. My guess is you are being bitten by the Mojave bug where the system "half thinks you have enabled accessibility and half doesn't", in which case you need to restart.

See: Accessibility Permission Problem

Hi Peter,

Thank you so much for your reply. I've tried rebooting (several times). I've tried uninstalling/re-installing KM twice (I uninstalled using CleanMyMac and then rebooted before reinstalling). I've also tried toggling the KM engine and app in Prefs->Privacy->Accessibility without success.

I was an engineer on the macOS team at Apple and would be happy to try anything else you might suggest.

Thank you again!

Might be a stupid question, but do you have "Restore Mouse Location" active in the macro?Screenshot_7_16_18__11_07_AM

Woops. Just re-read to see that there are previously-working macros now not.

@dashard Thank you for the suggestion but as you surmised that isn't my issue. :frowning:

Use tccutil to reset your accessibility permissions, then restart and start again (and read the wiki article and follow those instructions too).

Check the Console, I saw security related messages in the Console (shoot past since the Console is so full of noise these days) when the system half claimed that Keyboard Maestro had accessibility permissions and half refused to post events from it.

1 Like