New with questions


I just moved to KM from autohotkey and it is kicking my butt.

I want to use KM to enter prefilled text using strings. For example, I have it set to insert 08/01/2023: when I type !dd.

I am running into trouble in 2 places. First, when I use the text replacement, instead of it populating in the text field, it is triggering a popup box that needs to be selected before the text is actually populated in the box (seen below). Ideally, I would like to simply type !d d and have it populate without the popup and without me having to take the extra action of selecting the choice from that box.

Screenshot 2023-08-01 at 12.39.16 PM

Second, I have text I am trying to have populated that needs to be bold and plain, but all text is being populated with no formatting. I need it to have the first word of each section bold, then the colon and actual notes I add after to not be bold. Ex:

Therapy notes:
Subjective: aassddff

Objective: aassddff

Assessment: aassddff

Plan: aassddff

But when I input this using paste with formatting or using ** before and after a word in the executable text action, it always populates like this:

Therapy notes

No bold, no spacing, etc. The macro is below

Thanks in advance from a stressed psychotherapist that has spent ~10 hours in the last 48 trying to figure this out.

1 Like

I can help with your first query: the reason this appears

Screenshot 2023-08-01 at 12.39.16 PM

Is that you have two macros called Long date both with the same trigger. It’s called a Conflict Palette and allows you to choose between macros that have identical triggers. All you have to do is delete one of those macros and then the remaining one will trigger as you were intending it to.

Hope that helps and I hope someone else can help with your other question.

1 Like

Thank you so much! That makes sense, I created a copy of original macro folder to ensure I had a backup should I mess something up.


I should have said (but forgot) that if you disable the duplicate macro, rather than delete it, that will solve the issue too. So you can still retain your backup copy just in case and it won’t interfere…

1 Like

Disabling this was exactly how I fixed that issue.


Not an answer to any of your questions, but a worthwhile piece of information for a new user... When using the Keyboard Maestro Editor, there is File > Revert Macros for stepping back to a previous set of macros you've created.

1 Like

Where are you pasting the styled text?

Rich text on the Mac in the clipboard is sadly a little inconsistent (there is some discussion here Which applications accept pasting styled text… for example).

It’s going into a text box on a website we use for our clinical documentation. I am using Firefox as the browser.

Does the text box accept styled text pasted in normally?

I presume it's not publicly accessible so it's hard to duplicate, but most web text boxes don't accept styled text.