Notifications in macOS Monterey Show "Incompatible" App Icon

Has anyone else upgraded to macOS Monterey and uses notifications in KM?
Mine show this "no access"/"denied"/"not allowed" overlay, that I only know from incompatible apps.
KM notification icon

It's not a "problem", but it annoys me every time.

Hey @fab1An,


You’ve rebooted of course.

Have you tried downloading and installing a new version of Keyboard Maestro?

Make sure you move the new app by hand to its destination to avoid any translocation debacles.


1 Like

That looks like the icon you get when you have a 32-bit version of an app that can no longer run.

Check that you don't have an old version of Keyboard Maestro on your Mac somewhere.

I just went and checked my Monterey app, and sure enough it was doing the same thing in the Notifications. I restarted, and it went back to normal.

I forgot to follow my own advice, which is after any update, restarting one more time to get a fully clean restart.

Failing that, you can try going to the Applications folder, quit Keyboard Maestro and Keyboard Maestro Engine, then duplicate the Keyboard, trash the old one and empty the trash, and then rename the copy back to Keyboard


The Reboot fixed it. I'm working with the Mac for quite some time now, but only recently I read on at least two points about the method to better reboot twice after a system upgrade. Will try to remember. :slight_smile:

1 Like

Screen Shot 2021-11-19 at 3.26.13 PM

Anyone else getting this? I think it started after upgrading to Monterey, but it's only affecting Keyboard Maestro notifications.

I'm using KM10.

Pretty sure this is the whole point of the thread… :grinning: take a look at Peters suggestions in this reply.

It looks like my thread was merged into this thread. I searched before posting but didn't see this. A restart fixed it, thanks.


Makes sense! I couldn’t resist jabbing at ya but it was in gest. Glad you got it working!

You can take a shot a me, since I'm the on who moved Keith's post...



It's no problem. We appreciate mod efforts and it helped me find the solution anyways!