OCR stuck on "English - Downloading"

It's only 4ish megabytes, shouldn't take 20 minutes to download! I'm not sure how I could go about re-starting the download process (I've tried rebooting Keyboard Maestro, and the Engine, still sticks at downloading).

(edit: I've found the 'eng.traineddata' file in the application support folder - it's stuck at 'zero bytes' so it's just not downloading at all...)

Any ideas?

Have you tried after restarting the computer?

That sounds so much like the infamous quotation from the IT Crowd, “Have you tried turning it off and on again?”

Odd. The eng.traineddata’s existance should cause the file to be downloaded.


  • Quit Keyboard Maestro
  • Quit Keyboard Maestro Engine
  • Trash the eng.traineddata folder
  • Launch Keyboard Maestro
  • Reselect the English language.

Also, verify you can access the https://files.stairways.com web site, and download a file from there, since that is where the training data is stored.

Failing that there is probably some debug logging you can enable (I pretty much have debugging logging for everything generally).