Open URL With An Umlaut Fails

Hi Folks,

The action "Open URL" fails, when the URL is containing an Umlaut (ä, ö, ü) as in:ädte_der_Erde

Even when I replace the umlaut with: \%C3%A4% dte_der_Erde

Can someone please explain to me where the error is and how to fix it?

Best regards,

KM treats the %C3%A4% in the URL as "the Unicode token %C3% followed by the text A4%, which is why the URL doesn't work. (See the Other Uses for Tokens section of the KM manual for more about this.)

How you handle this depends on your macro. You can turn off token processing in the "Open URL" action if the URL is static test, but that breaks things if you are passing in a variable. So, instead, try "escaping" the % characters with another % so your URL text becomes %%C3%%A4%%.

How/where you do this will also depend on your macro -- if you post it then people can offer more specific help.

1 Like

Hi Nige,

Thanks for your post. %%C3%%A4%% does not work and turning off token processing does neither.

Hauptstädte.kmmacros (21.5 KB)

My bad -- somehow an extra % snuck into your first-posted URL and I didn't pick up on it. The actual URL is, which will work with all processing turned off or by escaping the %s as

1 Like

Hi Nige,

I really appreciate your help, but this link too does not work.

Edit: BUT the first solution (link and all processing turned off) does

Thanks a lot!

Best, Matze