Open with Finder AppleScript Bug in macOS 12.3

Having trouble launching documents for latest Logic Pro (X appears to have been dropped). I'm not gonna have to rename all those documents and rebuild all those macros, am I?

1 Like

What do you mean by 'documents'?

1 Like

My Logic Pro (was X) documents are are named with the .logicx name extension. The macros I was using to open them now yield error -1703. Is that enough of an explanation?

I'll do some troubleshooting. Now when I bounce the engine in KM Editor, I see an error message:

Excuse my ignorance but I don't know what you mean by 'bounce the engine' either.

Your Logic sessions should open via KM, but you'll have to change which app they open with as the application name has changed.

Shortcut observer seems to be linked to the app Shortcuts, so perhaps it's not compatible with the new OS...? Are you using that app as part of your macros? That might explain why they're failing...

Sorry if I'm not being much help.

1 Like

Not at all, thanks for your replies. By "bouncing", I just mean stop and start. I was thinking that might be a component of KM, but I'm not sure, so I need to do some research. I may indeed have an app by that name. Anyway, it's the -1703 that seems to be common for both the Logic error and the Shortcuts error so I'm trying to think what they might have in common. I'm not using Shortcuts for anything related to Logic Pro, I believe. I think I'll try disabling any shortcuts related to Shortcuts (that's not confusing, is it?), then rebuilding Launch Services next. Thanks again.

I have no solution for this yet. I did have launcher macro activated by launching the KM Engine, but I've disabled that. The issue that is causing me difficulty is that if I create a file launch shortcut like this in the Finder macro group then launch it using a hot key trigger,

I see this:


However, I can double-click this file in Finder, and it opens Logic Pro.
That's a problem I don't understand, and can't yet fix. Thanks.

One more thing:
If Logic Pro is not running when I trigger that hot key in Finder, It will launch, but today.logicx will not open.

Apparently, it's related to Launch Services, KM, and Finder, because the same error occurs if I create the same file launch macro in the Finder macro group for any .rtf file on the desktop. If I double-click it, it opens in without issue. If I trigger the macro, error message -1703 appears instead.

Uh-oh, this will probably be up to Apple.


Hi @Lantro. If you haven’t seen it already, check out:

1 Like

The problem isn't limited to Logic Pro. It appears to occur when an assistive app launches a document. If the document’s app is not running, the app launches, but doesn’t open the document. If the app is running, error -1703 appears. This AppleScript demonstrates the issue.

BTW, you won't have any problem running the AppleScript if you're using macOS 12.2.1 or older. It's simply a matter of enabling access in Security & Privacy prefpane. There may be a way to bypass it in 12.3 as well, but I haven't found it yet.

Here, try it yourself. Script is in /Applications/Utilities. Don't forget to use to create a file named "richtext.rtf" on your Desktop first.

set rtfile to alias ((path to desktop as text) & "richtext.rtf")
tell application "Finder"
open rtfile
end tell


Oh dear. I can confirm that this seems to be a bug in OS 12.3
All my open Applications Actions with Finder are broken :flushed:



I'm still on Catalina so I can't test I'm afraid. This might seem a bit facile, but what about changing the open actions' "with:" option to Logic rather than Finder? Does that make any difference?

I had an issue with opening files with Lossless Cut (a video trimming app). I got around it by setting my macro to open the app, wait till it was at the front and then open the file with the app. I appreciate this is more work than you may want to do. I suppose you could create a subroutine with the app name as a variable, but the wisdom of @peternlewis would probably be of help to you.

In the meantime, did you try @_jims' suggestion?


I have the same issue where I cannot get GarageBand to open Finder selection via Keyboard Maestro.

My current workaround is to activate GarageBand first and then make the GarageBand open the Finder selection.


Thanks @noisneil @_jims @RazMastero @Lantro @takashiyoshida
The "fix" seems to be to change the "open with Finder" to "Open with Default Application"

For an Application:

For a Path to a File (which can be a Variable)

But this is a pain (for me at least) because I have many Macros set up the other way, which worked fine yesterday... Not sure if it is worth changing them all as this is probably an OS12.3 bug rather than a feature.


I had the same issue and I had to change the way I open Files.


Hi @Lantro - I hope you don't mind, but as this seems to be a general bug in macOS 12.3 I changed the title of this thread to help others who are having the same issue. I bet it has affected a lot of people.


Good idea! Thanks.

I did report a bug using Feedback at, BTW.