Out of memory error activating Reason Studio app

Hello, new user with a question. I set up some macros to open applications using a keystroke. Most work just fine, but when I try to launch Reason Studio from KBM, I get an Out of memory error pop up:

This message appears 5 times, then the program will launch OK.

Reason Studio launches fine, without the memory errors, if I launch it from the Applications folder or using Alfred.

This is my macro

What can I do to avoid the out of memory errors?


Keyboard Maestro launching it will not affect the memory usage, but one possibility is the modifiers you are holding down at launch.

Sometimes Applications look at the modifiers at launch to change their normal behaviour, and you are holding down Command, Option, and Control, and that could do it. Try adding an action to the start of your macro to Pause Until the Modifiers condition shows no modifiers held down.


Other than that, you might have to ask the Reason Studio folks as to why they would be running out of memory, or maybe try activating the application by some other means and hoping that that does not tickle whatever bug this is in their code.

Hi Peter, Thanks for responding.

I tried your suggestion. Unfortunately even with the Pause action in place I still get the Out of Memory errors when starting Reason Studio.

To test your theory I tried launching the app from the Applications folder while holding those modifiers and the app started without showing the errors. Likewise, it started OK from Alfred with the modifiers held down. The Out of Memory messages only happen when activating via KBM.

For now, I shall start Reason the old fashioned way and keep thinking out this little issue.

Thanks again

I tried changing the macro to trigger by "The status menu item is selected". The same Out of Memory errors occur using that option.

I haven't had any issues in launching apps using KM over many years, starting with macOS El Capitan and all OS upgrades, except High Sierra, thru Mojave.
High Sierra did introduce some issues I did not like, so I stayed with Sierra until I upgraded to Mojave. OTOH, I don't have Reason Studio to test.

If you have Alfred and it is working well for you, then you can obviously use it.
As a third alternative, I use LaunchBar many times a day to launch and activate specific apps. It is very fast and I've never had an issue with it.

Thanks JMichaelTX.

Just want to restate:

  • the only app that has this problem in KM is Reason Studio, and, The problem only occurs when I launch Reason Studio from KM.
  • KM launches all my other apps just fine, and Reason Studio launches just fine except from KM.

The problem is peculiar to KM+Reason, so for that one app (Reason) I'll use other methods to launch it.

If there are other Reason users using KM to launch, please let me know if it works OK for you (and how) :slight_smile:

Interesting. I would suggest
a: using a different hotkey combo to launch Reason from KM
b: write to the Reason tech support and ask "if any of the support/dev staff use KM" and this might start a useful dialogue.

Thanks Jonathonl for your suggestions.

a. I have tried many combinations of hot keys and modifiers and in all cases, the error appears. I have also tried running the macro from the KM menu and that also shows the error.

b. Great idea :smile: I will contact the friendly support people at Reason Studios and see what they say, thank you.