Palette list extends beyond the bottom of my screen and doesn't scroll

I'm using version 9.2 of Keyboard Maestro on a 13" MacBook Pro (2018) running macOS Big Sur 11.3 with an external 24" monitor. I created a Palette macro following Kourosh Dini's book on Taking Smart Notes with DEVONthink v.1.3 and running version 3.7 of DEVONthink Pro. Following Dini's instructions, I created a Palette macro that, when I press the specified key combination, puts a palette on the screen showing all the KM macros in a long, single column list. I can select any item displayed to run the associated macro, or I can see the key combinations and use those.

However, the list of macros extends from the bottom of the menu bar on my 24" monitor and runs past the bottom of the screen--and I can't seem to scroll, move, or resize the displayed palette, so there are items below the bottom of the screen I can't see or access.

Any suggestions?

Randy Stokes

I assume from what you said that you should have something like this showing when you select your DevonThink Macro Group:

image

If you click on the Palette Style image above you'll see display options which can likely enable fitting your macro list into a palette visible on the screen:

image

Actually, no, I'm not seeing the Palette style window. How do I get to that?

Randy

Select the Macro Group in the left-most column of the Keyboard Maestro Editor.

Yes, I did select the applicable Macro Group in the left-most column of the editor, and nothing changes. No palette style window appears.

This is what appears when I select the applicable macro group in the left-most window of the editor:

I have found the Palette Preferences tab, and experimented by changing settings for the default palette style, which would appear that it would do what I want to, but none of those changes has an effect on the palette for my macro group.

You'll need to post explicit details of what you set up or a screen shot since I don't know if referencing Kourosh Dini's instructions has specific meaning for anyone here. Just in case, notice the selection focus in this image is on the left most column, not a macro in the middle column.

OK, here's a screenshot showing the new Macro Group on the left, titled Application: DEVONthink:

And here's a screenshot showing the actual macro created to show the keyboard shortcut palette:

Randy

Sorry, here's screenshot showing details of the macro:

Ah, okay. That's a different palette setup. If you select your Macro Group named Application: DevonThink on the left, then on the right switch Always Activated to the option Shows A Palette For One Action When the display will be like I showed earlier. You can assign the same Hot Key as you had (Command-Control-Option-D) and you can click the Palette Style image (like I showed in my first image above) to modify the palette layout.

If this is then satisfactory for you, you'll want to delete or disable the DevonThink Actions macro you have in the Palettes group or else using the same shortcut will activate what I've described and what you've already set up.

Perfect. That worked as intended!

Thanks for your help and your patience.

Randy