Paste Clipboard Not Working in Microsoft Word

I have five differently named clipboards (111, 222, 333 etc) into which I save text snippets which I wish to reuse. I have five keyboard shortcuts (^1, ^2, ^3 etc) to paste into Word from each of these named clipboards. The steps are:

  • copy 111 to system clipboard
  • Paste
    Until recently, all worked well.
    Now, when I use one of the shortcuts, Word ignores the 'copy 111 to system clipboard' and pastes the last item that was copied from within Word. I have tried adding 'Delete Past Clipboard 0', but that has no effect.
    Anybody got any ideas how to get around the problem?
    (Using Word 16.47 and Big Sur 11.2.3)
1 Like

Then you need to carefully review what has changed recently.
Did you update Word and/or the macOS?

My wild guess is that something else is using the same Hot Keys as your KM Macros.
Try changing the KM Hot Key, or just use "Trigger by Name" to see if that fixes your problem.

For more help, see Troubleshooting -- KM Wiki.

I have noticed a similar behavior with Word 16.47 and Outlook 16.47. Neither seems to use the system clipboard. If I manually copy text in either app to the clipboard, it appears that the copied data doesn't reside on the System Clipboard.

I use a lot of text shortcuts and was always annoyed that when I used "Insert Text by Pasting" (the fastest and most effective way to expand a shortcut) that it obliterated the contents of the clipboard. So after reading Dr. Drang's entry about text processing today, I decided to wrap these in "save the System Clipboard" steps. These clipboard-saving steps work in every app except Microsoft's Office apps. (Don't get me started on Excel's non-standard clipboard behavior...)

So it would seem that when you copy something in an MS app, it goes onto its own private clipboard. That's about all I can figure.


Some apps, perhaps like Word and Outlook, do NOT set the System Clipboard until the focus is moved to another app. Since they do not see the KM Engine as a normal app, they are not setting the System Clipboard.

So, one workaround would be to do the Copy in Word, activate another app, do whatever processing of the Clipboard you want in KM, then activate Word, and do the Paste.