Paste from named clipboard doesn't work on Onenote?

In named clipboard, I pasted a picture in it (also I tried jpeg, png), but when I execute “paste from named clipboard”, it doesn’t work, did not paste this picture in onenote.

However, when I tried to excute this command it works in apple note. And, when I paste text instead of picture, it also works in onenote.

How can I solve it?

Paste from Named Clipboard is essentially:

  • Set clipboard to Named Clipboard
  • Command-V

So the most likely cause would be that OneNote is caching the clipboard or otherwise not noticing the change.

If you copy something in OneNote and then run the macro, does it paste the thing you’ve copied, or paste nothing at all?

There are some discussions about pasting issues in the Troubleshooting FAQ at

Anyone been able to provide insight on this? Having the same problem.
Read the FAQ however still confused how to triage this.

Any shortcuts if accessible by the menu will work - however trying to use the clipboard doesn't work too well. Having the same issue with gmail via webbrowser
See another post

Anyone able to post up a working example?

Hey Jim,

Try inserting this action after any copy or clipboard manipulation actions:

Execute an AppleScript.kmactions (817 B)

I make no promises but it's worth a try to change the app-context.

If System Events doesn't work then try using TextEdit or another windowed-app.