Paste text macros stopped working

I use a few macros to type out my email address in a log in dialog. Until this morning they worked fine. I rebooted, deleted one of the macros and re-made it. None of them work. I have other macros that move windows around that still work using hot keys.
I tried changing the hot key for pasted text, to no avail.
Gmail address.kmmacros (1.9 KB)

Is the Secure Input mode triggered?

I ran the Secure Input Detective.scpt and it said nothing was running secure input.

I tried running the Find app with secure input but it's triggered by "The status menu item is selected" and I don't see a status menu anywhere to run it, so I'm guessing that just doesn't work. I can't find where the status menu is in any of the documentation either.

When the Secure Input is triggered, the KM engine will tell you. Click the KM engine icon on the menu bar, it will tell if the Secure Input mode is triggered.
Otherwise, there might be other reasons that KM does not see the typed string trigger, such as the macro group is not enabled, the macro is not enabled etc. From your screenshot, it looks both the macro group and the macros are enabled.

After installing your macro, I found out it was because you had set a condition to the macro group.


Change it back to "Always activated" and it will start working again.

1 Like

That was it, Thank you. It was driving me nuts!