Pasting in Bluestacks

I have an android emulator called bluestacks and I have some trouble using "insert text by paste"

When you paste a text in bluestacks, its actually CTRL+V instead of COMMAND+V, so when I hit the macro in bluestacks, the output is simply just "v"

Is there a way to make the insert text by paste function go for CTRL+V instead or perhaps there is a workaround to this?

Help! :frowning:

If you are actually using the KM Action "Insert text by pasting", then you might try these alternates, when Bluestacks is frontmost:

  1. IF Bluestacks has an Edit > Paste menu item, then use the KM Select menu
  2. Use KM Action Type a Keystroke, and enter CTRL+V

In both cases, you need to first set the clipboard to the text you want to paste.

1 Like

The thing is,

I need to have predefined paste text on different keys ..

If you could explain in detail what that means, then maybe we could be of more help.

Bluestacks does not have edit and paste menu item..

For example I need F1 to paste "hello" while F2 pastes "bye", predefined texts on different keys, this would be simple if bluestacks pasted using command+v.

it has to be PASTE, not typing..

Have you tried my 2nd suggestion:

Macro can be triggered by hotkey F1 or whatever.

Thanks you for your continued help.

Can you please elaborate on "you need to first set the clipboard to the text you want to paste."

Do you mean that I can for example hit F1 and it will execute keystroke CTRL+V unto pasting a specific text? And then same with F2, executing keystroke CTRL+V that in turn paste another specific text?

If thats the case, this would be the solution!

This is indeed the case. There is a specific action called "Set System Clipboard to Text" and it can be used in a macro in the manner you describe like this:


1 Like


Solved my issue :slight_smile:


Can someone please help me with this? What can I do to assign 2 different pasting commands into 2 different keys. (for ex: pressing F1 will paste "hello", and pressing F2 will paste "welcome").

I'm using bluestacks 5.2. I have tried using the text "hello" script command, but to no avail.