Pause Actions Stopped Working


My Pause actions stopped working! I tried to put like 20sec of pause, 20 minutes of pause, and they still get disregarded....And no, they are not desactived. I also tried to delete them and to re add them. I also restarted my computer.

Any chance someone would know how to resolve this issue? I'm attaching a simple macro that goes to one file to another one in Finder, the 20sec pause in between doesn't work on my side...

Pause issue.kmmacros (2.2 KB)

Your macro looks fine. There is virtually no chance that the Pause action is not working - something else is almost certainly going on.

I suggest you add a Log action before and after the macro, and then watch the Engine.log file (Help ➤ Open Logs Folder). You can open it in the Console, or tail -f it in the Terminal.

Possible guesses:

  • The macro is being triggered multiple times.
  • Multiple macros are being triggered.
  • A different macro is being triggered.
  • The modifiers you have selected are affecting the behaviour.

Put 0.5 sec pause before the first down arrow