Possible Bug: Copying From Clipboard History Switcher Does Not Work

Tagging @peternlewis, I am running into a potential bug, where clicking to copy a selected item from the Clipboard History Switcher does not actually update the clipboard. Therefore, pasting will still paste the topmost item. However, clicking to paste a selected item does work as expected. See the screen recording for an example. This is surprising, and perhaps (hopefully?) an edge case unique to my system/setup.

Screen Recording (click to expand/collapse)

Screen Recording 2023-10-18 at 16.20.33

1 Like

Funny, I tried to do this over the weekend and thought something was wrong with my machine. I swear it worked before. Anyway, I got the same results that you did. Thanks for reporting this @cdthomer.


In the gif (which is hard to follow because the looping makes it unclear where the start and end is), you first click the Copy button, but nothing is selected, so nothing changes except the window is closed. Depending on the target app, you may hear a beep when the Command-C fails (in Mail and Safari it does, in BBEdit it doesn't).

Then you Paste, which pastes the unchanged current clipboard.

Then you select the second entry and click Paste and it pastes the second entry.

So perhaps you are not understanding what the buttons mean.


The three buttons mean Cut, Copy, Paste.

The first two perform a Cut or Copy of the current selection, which will add the entry to the top of the clipboard history. The existing selection in the Switcher is irrelevant. If nothing is selected, then the Cut/Copy will fail and nothing will happen.

The third one performs Paste of the selected entry. If necessary, it sets the system clipboard to the selected entry, and then Pastes.

Cut, Copy and Paste are done by simulating Command-C/X/V respectively.

Sorry for the poor quality gif... not sure how to prevent it from looping, but I created another screen recording that might show it a little more clearly. But even in the first one, I have selected the second entry, which starts with ioreg, but when clicking the copy button, the only thing that happened was the Switcher closed, and the larger piece of text ended up being pasted. It might be a little more clear in this second screen recording. I’ve included a link to the original video file which is higher quality if you‘d rather see it.

Screen Recording (click to expand/collapse)

Screen Recording 2023-10-19 at 06.38.46

Link to video file on Dropbox

As you can (hopefully) see in the recording, I am selecting the first, then the third entry in the Switcher, then clicking the copy button, then attempting to paste those selections in my note. However, the first entry (which is an action’s XML) is the only thing being pasted. I can confirm that I am hearing the beeping when clicking the copy button, which seems to indicate that the copying itself is failing.

Perhaps I’m misunderstanding this part, but are you saying that it doesn’t matter which item in the Switcher we have selected to copy?

1 Like


I think I understand. I 'think' Peter is saying that the copy matters outside of the switcher. As in a selection within another application. So basically, we aren't copying within the switcher - which we thought we could do using the icon.

See this example. Maybe it explains it a little better. I'm sure Peter or someone else will correct me if I'm wrong.

Screen Recording



Yes, the Copy button, it the Switcher, simply copies the current application focussed selection.

What you have selected in the Clipboard History Switcher makes no difference.

It is essentially the same as closing the Clipboard History Switcher and then pressing ⌘C.

Yes, correct. It is copying from the application into the clipboard history, it is not copying into a specific entry in the Clipboard History Switcher - the selection in the Clipboard History Switcher makes no difference when copying to cutting from an application using those buttons.

The selection only makes a difference when pasting from the Clipboard History Switcher.