Possible Trigger Macro by Name Action Bug?

Every time I typed the hotkey trigger or ran the following macro within the KM editor, the search box was prepopulated with "trigger macro by name"as shown below.

I went through all the trigger macro by name in my macros and could not find a culprit.

The problem was solved by quitting the KM engine and editor.

The default behaviour for any list prompt action is to display something generic in the search field unless a user-defined default value is entered into the action.

The only thing that's a little odd is that the text isn't capitalised; it is on my system. Is that what you mean by a "bug"?

As @noisneil says – this is not prepopulation – this is a label of an "empty" dialog that might otherwise be confusing to the user.

And – it should indeed have been capitalized, so something got bollixed on your system.

If it happens again you should take a sample of the Keyboard Maestro Editor with the Activity Monitor, and send it to Peter.

@noisneil @ccstone

Thank you Neil and Chris

Problem:previous searches seem to "stick"

My understanding is that when i trigger the trigger macro by name action

  • Normal behaviour: the text Trigger Macro by Name appears as a grey EMPTY overlay over which I can just type (nothing to delete)

  • Bug? For some reason, KM seems to remember a previous search (I was previously searching for macros with trigger macro by name in the name which is why it is not capitalised - it's the way I typed in the search). The difference with normal behaviour is that to enter a search term, I first have to delete trigger macro by name in the search box.

I tried to trigger the trigger macro by name action many many time using different macros and different search settings and always ended up with the search box populated by trigger macro by name action.


Each instance of the "Trigger Macro by Name" action in your macros not only remembers your previous search, it also uses machine learning to bubble up frequently-chosen items that match what you are typing.

Because these are per-instance, Macro A's "...by Name" action will give you different "suggestions" to Macro B's action, even if you've typed the same string.

IIRC there is a clever way to reset them -- but the simplest method is to delete the action and then add it again!


OK. thank you

Hey @ronald,

@Nige_S has his finger on the pulse of this one.

What you describe above doesn’t happen to me (not exactly), unless I type the entire trigger name.

Here I've only typed “trigger” (enough to find the macro in question) and then activated it (now highlighted after running the original macro again):

For future reference:

Be wary of covering up or otherwise omitting important bits of information:


I’m not sure I would have glommed onto the problem had I seen the rest of the grayed-out text, but I might have. (I only use Trigger Macro by Name now and then.)


1 Like

It's clear now. Thank you @ccstone @noisneil @Nige_S

Now the problem persists. When I trigger trigger macro by name action I see the search box below.

  • no longer solved by quitting - restarting KM editor and engine
  • the persistent search ie red t: gesture was typed yesterday and I have used the macro many times since, so it's not a question of KM remembering the last search terms
  • as you can see the entire trigger name is not typed.
    thank you