Pro Tools - Macro to add a 1s "beep" (1000Hz) after a selected region

After my very complicated "dubbing" macro, which is almost perfect, thanks to Evan... i'm looking for a quick way to create a macro which does this :

  • I select a region, cut it as desired
  • press a hotkey which will create a 1 second 1000Hz "beep", at -30dB, just after it.
  • close the signal generator window

Any quick and reliable idea ?

Thanks a lot ! Still very beginner with KM, but learning a lot from you guys :slight_smile:

Xabi
Capture d’écran 2023-09-18 à 18.55.12

Any reason you prefer not to import the beep as an audio file if it's always the same length and Hz?

Nope.
Not a problem as it does the same.
All I need is a macro to just press one button and get a 1s 1k beep after the selected region :blush:

I don't use PT but I can imagine this might be simpler than generating a new beep every time... although I could be wrong.

The best way to figure this out is to mentally list the individual steps required to fulfil your objective and then translate them into a sequence of Keyboard Maestro actions. Something like:

Select menu (File→Imports→Audio...)
Pause until button enabled "Open"
Navigate to path of beep file (AppleScript pehaps? I can help with this)
Select "Add Button"
Press "Open" button
...etc...

If you get stuck along the way, let me know the exact steps you need to perform manually and I (or someone else) can help you get them going with KM.

There is a shortcut to make a beep clip.
Select a region and press:
ctrl+option+shift+3

2 Likes

Yeahhh. Damn, it was that simple...

Thanks !!!

But, here's what i don't understand, if i want to assign a macro on KM for this action, let's say F18, i create an action, set a keystroke, entering the command.. well, doesn't work. It creates me a blank region. Strange...

Any idea how i could manage to do that with just the F18 ?

Thanks in advance
Capture d’écran 2023-10-03 à 10.17.55

You have the wrong Keystroke assigned. It's Control-Shift-Option-3

I'm French, with a French keyboard, maybe it's because it doesn't work?

If I type the 3 on the numeric keypad, it doesn't work. (I mean, the combination control shift option 3)

If I type it like this, with the " (which is the same key as 3 on the top part of the keyboard here) it works fine straight in Pro Tools, but the macro doesn't... Really weird...