Problem sending text to a Windows 10 VM

Morning, everybody.

I work very often with this set of macros that I attach in the link. They are strings of text that are written in a virtual machine with windows 10.

In the attached video you can see that if I click on the macro and I orient it so that it writes the text in textedit in mac, the text is written correctly, but on the other hand if the text is sent to the windows 10 virtual machine, the shift key is activated randomly and the text is altered.

Does anyone know what this may be due to?

Here the video link

I tried twice to watch the video but it refused to load after 10-15 minutes. Could you upload to Youtube?

Here's something from the author of KM regarding a different problem someone was having with a VM:

You implied that the macro worked at one time but has stopped working. Is there any change to the VM that you made between then and now? As Peter wrote, VM settings can be the cause of problems.

The macro works correctly outside the virtual machine, but within the virtual environment, capital letters are activated randomly.

The problem is not that it works once and then stops working, every time it is invoked it works correctly, but for something I am unable to locate (I have spent hours on it) the shift key gets in.

I had hoped that someone here would have had a similar problem, but I understand that is something very specific ...

Uploading it to youtube is a delicate subject. Could you try downloading the video instead of playing it? Thank you!

I was able to download the video. And I watched it. Thanks. I see your concern now. Sorry about mentioning Youtube, I didn't know that was a sensitive subject.

Clearly Windows 10 is receiving the wrong string from time to time. So the question is, is the data being mangled by KM, or by Windows 10, or by the software used by the VM to interface between the two operating systems, which is usually called the hypervisor, I believe. My guess is that the problem is inside the hypervisor. In other words, KM could be sending the data correctly, and Windows 10 could be receiving the data correctly, it's the VM hypervisor in-between that's messing up. So can you tell us what VM software you are using?

It sounds like you are saying that this macro has never worked correctly before. Which means you probably didn't break it by changing the VM. That's too bad, because it means we never had a working configuration.

In any case, even if it's not KM's fault, we may be able to change KM's behaviour a bit that could fix this. Which action in KM are you using to send the string? There's a chance we might be able to change the action to make it work, even though KM may not be at fault here. For example, we can perhaps change the speed at which keys are sent. KM has a configuration action to change that, which is this:

Perhaps if you played with the number in that box (raise it up a bit) you might be able to get the VM control software to receive the correct data. If that doesn't work, I have another idea, but this is the simplest idea for starters.

KM does not really support any type of virtual machine, so I'm surprised you are getting any text at all.

I think about the best you can do is to use KM to set the System Clipboard, and then manually switch to the VM and paste. Most VMs support shared use of the Clipboard.

First of all, thank you all very much.

After reading your answers, I have chosen to avoid the virtual environment. I have a small physical multimedia server at home in which I have decided to replicate the conditions in which I have to work.

I connect to it via remote desktop, and the effect LOOKS, but not the same.

In the virtual machine upper and lower case were interspersed without apparent sense, now it seems that the problem is that when sending the keystrokes, there is some kind of delay when applying the shift key.

Example the same phrase put several times in the virtual machine, scenario 1.

Zer moduz aUto berRRIAREKin
Zer moduz auto berriarekin
ZeR Moduz AUto berriarekin
Zer moduz auto berriarekin
ZEr moduz auto berriarekin

The same phrase put several times via remote desktop, scenario 2.
Original sentence: Hori ezin da ukatu Noski

HOri ezin da ukatu noski
Hori ezin da ukatu noski
HoRi ezin da ukatu noski
HOri ezin da ukatu noski
Hori ezin da ukatu noski
Hori ezin da ukatu noski
HOri ezin da ukatu noski
Hori ezin da ukatu noski
Hori ezin da ukatu noski

In scenario 2 we have the added problem that the capital N of "Noski" never appears as a capital letter.

I leave you some captures of one of my macros (almost all have the same structure) to see if you see something that I do not see.

And for scenario 2 to be clear, it's a remote desktop with a copy of windows 10 pro running on a physical server.

Saludos!




I've tried, but the characters have to be typed one by one for the purpose I need...
Thanks anyway!

I searched the internet to see if anyone else had your problem, and I found some problems that were similar to yours and these ideas were discussed for those cases:

  • reboot the Windows VM
  • reboot the macOS VM
  • reboot the hypervisor, or see if your hypervisor has utilities that can be reloaded to address this. I found a webpage that says that VMWARE has had problems like this and that it can be fixed by re-installing VMWARE-TOOLS.
  • try restarting the VM with "run as administrator" instead of non-administrator
  • run a clean reboot of the host and guest VM, disabling all non essential services
  • try increasing the value in the "Set Simulate Normal keystroke Delay for this macro" action (easy to test)
  • try the same thing on a different Mac to see if the issue carries over onto the other hardware
  • try using the macOS Keyboard Viewer and see if it also causes case changes. I'd be very curious to know whether the macOS Keyboard Viewer can even be used to send keys to a VM.
  • check if the hypervisor has communications settings that affect copy/paste.

I'll bet if you tried all these ideas, you'd find a solution.