"Prompt for Input" prompts that are too tall

I often use "Prompt for Input" actions as debugging aids. I made the mistake of displaying a long XML string today, and I couldn't find any way to close the prompt. No keystrokes, nothing. I finally had to kill all macros to get it to go away.

Any ideas on how to dismiss a prompt like this?

Also, it would be kind of nice if the prompt limited itself to the size of the screen (@peternlewis).


An ESC will usually press a standard Cancel button on the Prompt. did you try that?

You can cancel selected Macro if you want from the status menu.
I have two Cancel Macro macros:


Thanks, and good point - I forgot to mention that the prompt only had an "OK" button. Probably shouldn't do that again. :roll_eyes:

You can cancel selected Macro if you want from the status menu.

Yeah, I have a "red button" hot key that aborts all running macros. I don't use it much, but when I need it, I'm sure glad it's there! Especially if I have a runaway macro that's moving the mouse all over the place - makes it kind of hard to access the status menu. :open_mouth:

Thanks for your help, Jim!

That happens to me at least once per week. So I mapped my backquote character, which I otherwise rarely use, to a "cancel all macros" action. And I use that every 5 minutes.

When I've accidentally disabled the group it's in, and the mouse isn't working because of my macros, it can sometimes require a hard reboot.

I'm more prone to this sort of problem because I have macros that require triggering on the primary and secondary mouse buttons, so I've remapped those buttons with my mouse driver.

We do it to ourselves, don't we? I'd comment more, but we're getting off topic.

1 Like