Recently, Thunderbird will neither activate NOR bring the window to the front

I have a series of simple macros that just activate an application e.g. Safari, Activity Monitor, System Preferences etc. and bring the entire window to the front.
On all of them, they activate but recently, Thunderbird will neither activate NOR bring the window to the front. the front window to the front.

It would appear that if any small "part" of the thunderbird is at all visible, then it considers it un-necessary to do anything.

What are the criteria being used, and why just Thunderbird?

Using Sonoma and latest KM.

I'm not sure I can solve your problem, but I have to ask if you have ever re-installed Thunderbird. If yes, then you may have to reselect Thunderbird in all your KM actions which refer to it.

Bit more investigation
Nothing was being written to the engine log
so I assume it was not being triggered
Changed trigger fro CTL+CMD+T to CTL+CMD+`
Worked fine
Q: How do I find if any other KM hotkey is using CTL+CMD+T?

There's a free app called ShortcutDetective that will do the trickā€”almost always, that is. There are some apps it can't see, but I've found it quite good at what it does.

-rob.

I think the culprit is CAPTO from Global delight.
Screen capture utility
I do not always have it running and their default hot key for timed screen capture with 5 sec delay is CTL+CMD+T.
I had it disabled in the past and it is now disabled

CAPTO definitely the culprit even with the hotkey combo changed/disabled

Just tried ShortcutDetective and it crashed. :frowning:
actually after trying several times, it works for a bit then crashes...

also for completeness a trial version of Keycue might show it

Huh; it works well here. Durn.

-rob.