Record-Quick-Macro action hangs for a long time when activated

Today I'm getting a LONG hang when pressing ^F2, which simply launches:

It EVENTUALLY pops up the recording button but takes a long time.

I quit and re-launched the Keyboard Maestro engine, and tried changing the hotkey, but this still happens.

I can try rebooting the machine but too busy right now :stuck_out_tongue:


1 Like

Hmmm … I use quick macros frequently on my MBP w/Mountain Lion.
No problems here. Perhaps a reboot is in order.

Mike Briggs

No idea if this is the problem you have, but I found that for some reason I still didn’t figure out, sometimes actions don’t take place on my MBP until I move the cursor. It’s pretty weird, but since I still don’t know what’s causing it, that might be worth checking. So the next time it seems to hang, try moving your cursor.

I have the same issue. It’s frustrating. I also have an issue when recording steps in a regular macro. Started a couple months ago. My “solution”. If the countdown doesn’t start, I right-click any icon in the dock. The countdown starts. I realize it’s not very scientific but it works.

I wish I could find something that would nudge the Quick-Macro in a similar way.


Just tried using this again (now on new computer, a Macbook Pro), and again getting the hanging–in fact, the whole Keyboard Maestro Engine hangs, too–I have to use app Tamer to relaunch it.

Anything to try?


  • changing shortcut -> no difference
  • rebooting (with the new shortcut) -> 1st time still very delayed; subsequent times working fine

Ah-HAH! App Tamer reliably causes the problem! With it off, I can use my shortcut!

Well, that is ironic. I was going to suggest if the issue happens on a new Mac, then look at what software you installed on the new Mac.

ajg23: What applications do you have App Tamer configured to control? App Tamer shouldn’t impact Keyboard Maestro unless KM tries to communicate with an application that AT has stopped in the background.

1 Like

Sorry wasn’t around for awhile. I don’t think was actively slowing anything, but I didn’t change the defaults since new Mac install.

New info:

  • at one point I had the record-macro hang with App Tamer NOT running…and I launched and quit App Tamer and then it didn’t hang when I tried again!
  • just now tried turning App Tamer OFF via its settings, and it doesn’t seem to interfere w/the record-macro function…

Currently have App Tamer QUIT as part of the record-macro macro, but eventually will look up syntax just to turn it off without quitting :slight_smile: