I am trying to fill in a password to a program to open it. The password changes often, so it is tiresome to keep looking it up. (It is not financial data so it is not sensitive) I probably do not understand how to use the recording function. I want to open the program, the recognize the cursor which is automatically in the field where the password should be pasted. Then click the ok button so that the application will open and I can start working.

I looked at tutorials on recording and it looks simple. I don't understand what I am doing wrong.

I don't have the program so I can't test, but initial thoughts are:

  • You shouldn't need to activate RadarOpus again, once it's at the front.
  • What is the first click doing? I thought you said the password field was pre-selected...?
  • You haven't told us what isn't working. Is the password being pasted ok? If not, have you tried Insert text by typing? Password fields don't always allow you to paste.
  • Perhaps you could simulate pressing the enter key rather than clicking the OK button. Not important at all, but that's usually my preference.
1 Like

Thanks for your reply.

I tinkered more with it. You can see the field where the password needs to be pasted.

I am able to get the application to open and the window asking for the password comes up. I am unable to get past that stage.

I watched the excellent Youtube instructions by KJMiller

Then, after failing with all of his tweeking of the pasted image, I decided that maybe that is not the best method for me anyway.

Then I tried the title of the window where I want to paste the password. And I tried your idea of typing. I can paste it manually, so I don't think that is the problem. Anyway, I did not succeed.

Sorry, I have pasted the same image twice and do not know how to remove it.

You have changed the pause from until RadarOpus is at the front to until RadarOpus is running. Was this a conscious choice?

Regardless, the first thing I would do is to disable everything except the Insert text by typing action, and trigger the macro to see if the password is entered successfully. If it is, then the problem is to do with either timing or window focus.

So, start building the macro close to the final action. Makes sense. Thank you.
I did as instructed. I made some additions.

The result is as soon as I touch my touch pad, the macro finishes and the program is on. Apparently the password has been entered.

That is an ok result, but I would like to make other macros like this. I should not have to touch my track pad, it think. Greedy me.

Could you clarify? Do you mean you have to touch your track pad at some point during the macro run for it to complete? I noticed that the found image click you added is a right-click. Is this intentional?

I am dyslexic. I made a mistake. It should be a left click on my trackpad.

No, you are right. Touching my trackpad does nothing. The program just does fill in the password. Isn't there something where the macro will beep at me and then I can manually put the cursor into the pop up window? The problem seems to be that the macro cannot find the popup window even though I put in a "found image." I just want to avoid having to constantly look up passwords for applications that I use frequently.

(Actually, I should make an easier to remember password. I am not giving up because I would like to succeed in something with these macros. I have a bunch of unsuccessful macros. )