[RESOLVED] System Speak Text Stopped Working after updating to MacOS Mojave 10.14.1 Update

I just updated to 10.14.1 and now the Engine crashes (more specifically it says "(Not Responding)" in the Activity Monitor app) whenever I try to run a macro with Speak Text or even just try it in the editor.

After multiple attempts of force quitting the engine and restarting the editor/engine, and changing the voice settings within the editor, I've been unable to solve this problem.

I originally thought it may be related to the Mojave update because of the timing of the bug (it worked great yesterday), but after reviewing the release notes below, I'm not so sure that Group FaceTime and new emoji characters would effect the speech api, but I dunno...

Can someone help me debug this? Below are my logs.

Thanks in advance,

Engine.log Output:
018-11-12 12:32:47 Execute macro “1. Display/Say Next Action” from trigger The Shared Remote Trigger 38D46E84-CA65-4D23-BDA2-A0FD87AF4583/C5376806-CCB1-4188-8BA4-DCDB7FA03467 is accessed
2018-11-12 12:32:52 Action timeout exceeded. In macro “1. Display/Say Next Action” (while executing Speak Text “Next on your list”).
2018-11-12 12:36:13 Engine Starting 8.2.4
2018-11-12 12:36:14 Starting web server on ports 4490 and 4491
2018-11-12 12:36:31 Action timeout exceeded. In macro “Trying” (while executing Speak Text “Next on your list”).

Update: it may be a bug on my machine, when I tested the voices in Accessibility it crashed my settings, going to investigate further...

Urgh. Restarting computer fixed it. Dumb 1998 solution to a problem I over-thought.

Issues Resolved.

1 Like