Right click not working in Java Application (PDF Studio)

When I right-click in Microsoft OneNote for Mac 10.13.6 High Sierra, right-click works as expected, but when I try the same macro in PDF Studio, a Java application, there is no reaction, nor is there any reaction if I send Control+Shift with a left-click. If, on the other hand, I manually right-click or press Shift+Control click, the right-click menu works.

Apparently this is the same problem as this thread: Emulating “Right-click” or “Control-click” in Java-based apps


I think this is a "timing" issue. I was able to "work around" the problem by holding the right-click key, pausing, and then releasing the key. Alternatively, dragging during right click worked, presumably because it adds a similar delay. I'm not sure if this is a bug in Keyboard Maestro, a Mac problem, or something else.

This worked:

And this worked too:

Hey @mellowyellow,

I'm glad you found a solution.

These kinds of issues can be very finicky and sometimes impossible to solve.


Thank you very much!

I've been looking for this for many months. I've used your solution in this macro for CafeTran Espresso 2019, also a Java app: