Safari 16.1 (after Ventura upgrade) does not respond to KM macros

I just updated to macOS Ventura and now none of my KM macros for Safari work. Anyone else experience this? Any thoughts for a solution? Other apps seem to work fine with KM.

Yes, I've had some issues. To fix I had to re-select Safari anywhere it's referenced, such as the "Available in these applications" Macro Group menu and "Send keystroke to..." settings . It looks like the selections changed to some kind of alias after the upgrade.



Same here, the problem is I have 10 CPU's that use the same macro set. 2 of them are on Ventura, the others on Monterey. If I fix the Safari group for one OS, the other OS does not work and vice versa....

That worked, thanks so much!

Re-selecting Safari worked for me for a while, but today the problem returned where the selection is changed to the alias-like icon.

I'm not sure if it's because I installed the Ventura 13.0.1 update yesterday, or if it's because my KM macros definitions are shared (via iCloud Documents) with other Macs running older versions of macOS.

I can confirm that the "fix" only works for a short time if syncing Macros between Macs where some are not on Ventura. After a few minutes the Ventura Mac is showing the Safari App with the Alias symbol again and the Safari Group of Macros don't work. @peternlewis are you finding same behaviour?


Syncing macros between Macs with applications at different locations or different versions of applications, will always be a problem, since if the application does not exist at the specified location, it will be re-found, which results in the macros changing.

You may be able to adjust the configuration of the popup menu to only use bundle-id.

But it does depend on what on earth Apple have done as far as faking Safari in the Applications folder.

1 Like

Yes, that seems to have done it. Safari Macros are now working on both the Ventura Mac and the other Macs on Monterey with all Macs syncing Keyboard Maestro Macros. And this has been the case for the last few days so it seems like the setting is remaining.