[Solved] Safari Macro Group Is Disconnected From Safari After Ventura Update

There do appear to be some issues with Launch Services and the speed with which it is updating its databases after upgrading to Ventura.

Mine are working fine since 3 days ago when I made the change.

Yeah, this is not good. Something weird is going on with your system...

Use Interactive Help in the Keyboard Maestro Editor's Help menu, and run it on one of the macros in question.

image

If that doesn't help you troubleshoot the issue then:

  • Rebuild LaunchServices with the appropriate version of Onyx.
  • Reboot.

Hi @ccstone,

Have followed your advice and, rebuilt launch services database plus restart.

So far, fingers crossed as it's just twenty minutes ago, it's worked.

Many thanks for your helpful advice.

1 Like

Rebuilding the Launch services database (use Cocktail or Onyx) followed be a restart worked for me.

1 Like

Yeah, same thing here something is going on with the Ventura update. Quicksilver seems to keep struggling to find Safari. After a couple of days, Safari keeps getting forgotten as "Available in these applications" I select it from the open apps and am good for a short bit. I'll try rebuilding launch services and cross my fingers that it sticks. Thank you.

Another data point: creating a new group and dragging the old macros to it likewise worked for me.

2 Likes

same here, tx for solution, worked fine!

1 Like

I take it back. Today it's not working again.

I had much the same experience. Creating a new group and dragging the macros in there or creating a new group and re-creating the macros seemed to work but often in twenty minutes or so (sometimes 15-30 hours) they would stop working. On the advice of ccstone I rebuilt the LaunchServices database and re-booted. Since then the Safari group macros have been working and its a few weeks ago I dd the re-build. I used Cocktail to rebuild the LaunchServices database but Onyx I think does it also and is free. Maybe give that a try>>

1 Like

Unfortunately, it didn't help at all. I used Onyx to do the rebuild.

This has worked for me:

1 Like

Worked for me too. It's been a week and no problems.

1 Like

I am now on Safari 16.2 and we are back to the same issues again.
image

Did you try 'rebuild launchservices database'? It really worked for me(and on Safari lates)

Well, that's not Keyboard Maestro's fault...

  • Complain loudly to Apple!
  • Delete all the Safari Listings in your Macro Group.
  • Rebuild your LaunchServices Database using Onyx.
  • Reboot.
  • Reset Safari in your macro group.
  • I'd also try using ‘Match by Bundle ID’.
    ⠀⠀image

Yeah, sorry, I should have made that more clear that I didn't blame Keyboard Maestro. I wouldn't even know how to complain to Apple about this one "I have this problem with third-party software..." at that point they stop reading and move on.

Thank you for all the tips. I didn't realize those other options were there. Match by Path should also do the trick; thank you very much. I had to update this again this morning. Strange, I wonder what is causing this. I also notice that on an M1 Mac, several sites think I am on iOS, so the browser must be doing something to make sites think I am on a mobile device.

I cleared things out with Onyx and restarted; we'll see what happens, and I'll plan on posting back. I left off the Match option for now, hoping that fixes things.

@peternlewis – have you reported this bug? If so could @skillet leverage your report?

The bigger the dog pile the better...

1 Like

If you mean the issue with Safari moving and there being some sort of “alias” to Safari in the Applications folder, no, I have not reported it to Apple as they will not consider it a bug.

It's part of Apple’s security hardening, they have moved Safari into a location where it cannot be modified by non-OS processes.

I have no idea why you would get a dozen Safari’s listed in the menu though.

@Zabobon this was a super helpful tip. I also had my Safari macro group stop working after updating to macOS Ventura -- I never would have thought to look for a SECOND Safari icon :joy:

2 Likes