Safari: how to select from a dropdown and click a button

I use a KM macro to fill on many of the tedious information on the Amazon selling page.

There are two things I cannot figure out how to do.

  1. There is a dropdown for the items condition. I cannot select from the menu, e.g. I would like to set this to “Used - Like New”.

  2. There are two buttons I would like to press:

“Calculate Fees”
“Match Low Price”

Any assistance would be greatly appreciated.


It depends on how the web page is built, but you can often use the Set Safari Field to Text action to set a dropdown menu, for example on the example web page:

You can use this action:

to set the field.

You can use the Safari dropdown menu in the action to find the available fields.

You can use the Click Safari Link for that.

But all of this depends entirely on how the web page is written, and web pages can be written in bizarre and convoluted ways that wont work - for them you need either to drive the UI (with clicks, maybe click at found image), or with JavaScript.

1 Like

Thank you for your suggestions. Unfortunately neither of them worked. The page is very convoluted.

Did you ever find a solution?

If so, please post it for the benefit of others.
If not, let us know what you have tried, along with some specific examples and web pages.

Unfortunately I have note. And sorry for the very tardy reply.

I cannot get the first drop down to change.

Here is the start of my Macro:

And here is what I see when I inspect the element. It is a dropdown button, but no matter what I do I cannot change the default value.

FYI, that image is too small to read, at least on my machine.

Dan, that's funny, I reduced them because I thought they were going to be too big.

Let me try again with the actual sizes.

That’s better.

The forum automatically shrinks images that are “too large”, but you can still click on them and see them in their original size. So it’s usually best to just stick with the original image.

By the way, I don’t know the answer to your question. :slight_smile:

That cracks me up! Well, maybe someone else will come along and answer it.

I am suspicious that Amazon changed the page in order to make it harder to use automation tools…

1 Like

Could be, or possibly they changed it for other reasons. In any event, the only elements in the section you highlight are spans of text, marked up with fancy CSS presumably, and probably implemented with JavaScript.

You might have to resort either to JavaScript hacking of the web page (figure out what JavaScript runs when you click there and run it directly), or alternatively UI control (click on the element).

Where did you get the "Used - Like New" text? Did it come directly from Amazon? If not, that might be (part of) the problem. For example, in my eBay macro, the duration dropdown reads "5 Days" on the site:

But the format required to change that is Days_5. You can learn the proper format by having the page open, and seeing what the live preview shows as in the KM editor:

Perhaps your "Used - Like New" needs to be condition_used_like_new etc. I'd go check myself but I don't have an Amazon sellers account.

Good idea. So I fiddled around until I understood how to use the live preview. When I selected "Used - Like New" in the UI, the value in the live preview was "used, like_new". So I thought I have it. So I changed the value in the dropdown to "used, like_new" and it still doesn't work. I tried several other values and none of them work!

Maybe someone out there does have an Amazon seller account and can take a look at this. It I driving me crazy.

Yes unfortunately you’ll probably have to tinker until it clicks. I’m not sure how the Amazon page is formatted; for some actions I need to click a radio button or similar first before the changes KM makes will actually “take.”

In that eBay macro, I have to click the “schedule to start on” radio button BEFORE running the macro that sets the date and time. If I run the macro first, it will change the date and time, but clicking the dropdown arrow doesn’t show any options, and posting the listing throws a “must have a starting time” error. Maybe there’s something similar going on at Amazon.