Save Recent Applications Between Launches Bug?

I have "Save recent applications Between Launches" disabled. However, the Application Switcher continues to show greyed-out application icons for apps that are no longer running. And If I accidentally release the Application Switcher keystroke on a greyed-out application icon it starts the app.

I'm trying to find a way to shut that feature off, because I find it extremely annoying. I only want to see applications that are running in the Application Switcher. I don't care to see apps that are no longer running. And I don't want to have to keep clearing the "recents" menu.

I am running Keyboard Maestro 11.0.2 on Mac OS X Version 14.2.1 (Build 23C71).

How can I resolve this issue?


Screenshot 2024-02-02 at 12.18.55 PM

Screenshot 2024-02-02 at 12.19.30 PM

I don't use the switcher myself, but looking at its action, it should be easy to change:


Just uncheck anything you don't want to see—Recent Applications in your case.


Thanks for the reply! I have disabled all the Application Switcher and Launcher options wherever I could find them but I still have the issue. I even restarted the app after disabling those options, but no luck.


I am definitely not seeing that here; I only see running apps in the switcher.

Maybe try restarting the KM Engine (File → Quit Engine; File → Launch Engine). If that doesn't help, we'll probably need @peternlewis' expertise to explain what might be going on.


Unfortunately that does not help. I've been using KBM for a few years and never seen this happen. It's only been the last couple of weeks.

What I am just now realizing is, I updated MacOS to Sonoma a couple of weeks ago. That's the only system change I can think of that may be contributing to this issue.

@peternlewis could the Sonoma upgrade be the issue?

And i was testing on old KM (10) and old OS (Ventura). I on my laptop now, which is KM11 and Sonoma, but I'm not seeing recently-used apps in either the switcher or the launcher.


I appreciate you checking on Sonoma! I don't know what's happening. I have all the correct options disabled and I still see recently-used apps in the switcher. I even rebooted my MacBook to see if that would help. No luck! The only way to not see recently-used apps is using the clear option in the recents menu. But that only works until I kill an app.

I guess I need to open a bug ticket.

For a minute, I thought you might have figured it out—I always disable all recents, so my menu is always empty. But I enabled it, launched and quit a few apps, and they still don't show as ghosts in the application switcher.

Oh well, it was a good theory.


Activate the application switcher and click and hold on an icon, and you can see the options for what is displayed in the Application Switcher, including displaying recently quit applications.

See: Activate Application Switcher action.


Thanks @peternlewis! That did it. I didn't know that you could access a context menu that way on the switcher.