Screen Recording Disabled

There is a warning message just under the Keyboardmaestro menu bar icon, saying that screen recording is disabled, this in spite of having given permission to Keyboardmaestro in the screen recording system preferences. How can you resolve this?

Hey @Geoffrey,

  • What version of macOS?
  • What version of Keyboard Maestro?


This did the trick for me:
"In Big Sur and later, you can actively add the Keyboard Maestro Engine to the Screen Recording permission in the System Preferences, Security & Privacy, Privacy, Screen Recording settings by unlocking the System Preferences, and then finding Keyboard in the Finder, control or right click on it, select Show Package Contents, drill down in to Contents, and then MacOS to find the Keyboard Maestro, and then drag that in to the Screen Recording settings."

I'm was having the same problem as Geoffrey in Big Sur 11.6 20G165 and the latest version of KM: 10.0.
The alert states: "Screen Recording permission is needed to capture images of the screen, or find images on the screen. Please enable Screen Recording for Keyboard Maestro and Keyboard Maestro Engine in the Screen Recording section of the Privacy section of the Security & Privacy system preference pane." The problem was how to find the Keyboard Maestro Engine to add to the Screen Recording section.


I also had this issue - as a very new user and was immensely confused, especially as I couldn't find the engine anywhere on my system. I eventually thought of doing a right click on the app itself and choosing 'open package contents', then went through the folders, found the engine, made an alias and dragged it to the applications folder. That way it showed up as an app to be selected in the privacy section of System Preferences. That approach might be overkill, but at least I'll be be able to find it again if I need it.

1 Like

That worked a treat! Thanks very much.

BTW. OS 12.0.1 and KM 10.0

1 Like

Thanks for posting this. That warning was bugging the heck out of me :wink:

1 Like

Thank you for posting this. I have been all over the internet to find a fix for this. I had ticked in screen recording but to no avail. I could not figure it out.

1 Like

Thanks. That worked perfectly.

Hey Folks,

See post #3, and here's a cheat:

Finding the Keyboard Maestro Engine in the Finder