Selecting menu item not working after updating to macOS Sonoma

I have several simple Keyboard Maestro macros that open recent files in an app. For example, in Excel, I have a macro that selects 'File' then 'Open Recent' menu items. Before updating to macOS Sonoma, these macros worked fine. But after updating, the macros can select the 'File' no problem but cannot seem to find 'Open Recent'. Any idea what problem is?

Howdy, have no fear, this is well documented here on the forum: :wink:

Search results for 'sonoma menu' - Keyboard Maestro Discourse

Hi, I've been through those threads. Am I right in saying there is no solution for this yet?

From how I understand Peter’s comment in this thread, there’s no solution yet as it’s Apple’s error they introduced with Sonoma. Relevant portion quoted below. ↓

I have a simple macro that opens a folder based on whether a different folder is open or not. The macro worked fine before Sonoma, but it's now opening two different folders for some reason. Is this likely to be due to the same issue?

Impossible to say without seeing your macro. Start a dedicated question thread.