Semicolon and other characters not working in typed string triggers

Hi all,

I have lot of typed-string triggers for my macros, and use them for a majority of my triggers.

For a lot of them, I use a semicolon before the string to avoid triggering the macro when typing a word that has the same letters as the string. For example, if I have a macro that adds a signature, I would use ";sig" as the typed string trigger instead of "sig" so that I don't trigger the macro every time I typed something like the work "signal" or whatever else word has "sig" in it.

They work great on my laptop; however, I tried to import them to a client's computer, and the typed string triggers that included other-than-letter characters, like the semicolon, did not work. I also tried to rebuild the macros from scratch on the client's computer, in case there was an issue around importing the macro. Strings that included only letters worked on her computer, but once I started using other characters, like semicolon or colon, the macro would not trigger.

Note that I was controlling her computer remotely via Zoom (also tried with TeamViewer). I asked her to try to type the strings from her end, in case there was some kind of issue / conflict with key translation when working on the remote control software, but it didn't work, even when she did it directly from her computer.

Any suggestions or insight would be much appreciated!

  • Jeff

Hey Jeff,

There are so many possibilities, but my best guess is that the accessibility permissions on her system didn't get set properly.

This has been increasingly problematic since Mojave and is due to Apple's negligence.

See this: TIP: Resolving Big Sur Accessibility, Security, and Other Issues


If ccstone’s suggestion doesn’t work, my question would be; is the macro triggered without the “;”? If so, here’s how I designate my string triggers; I start all trigger strings with:

“z” + “z” + shift

Your trigger in this case would be “zzSig”

My trigger for going to tab #1 is “zz!” (aka “z” + “z” + shift + “1”)

Now, having said that, I too would be rolling my eyes if somebody suggested I change all my string triggers - physically in all my macros, and mentally in my head. Good luck!

That is very weird. My guess is that the non-letter characters are somehow doing something else which is clearing the Typed String buffer, for example simulating a mouse click or such. You might be able to use a keyboard monitor app to see if there are any strange invisible keycodes coming in on her Mac. Perhaps related to the remote control of the Mac, or the keyboard being used, or something else on the Mac (like a USB device sending events).

There are ways of debugging the Typed String system, you can contact support (Stairways Software: Contact Us) for information on how to do this.

Thanks for this Chris!

VDOCutter, thank you this is a good workaround!

Thanks Peter. Yeah, very weird. I will try the keyboard monitor app, and if that does not work, will contact support team for debugging. Appreciate the feedback.