Shift key sticking in macros

Hi, I’ve just started trying KM as I hoped it would help with a project.

I’ve made two macros for doing a repetitive task in the 3D software Blender. The two macros are as follows:

Shift-S keystroke
’4’ keystroke
pause .2 s (I thought this might fix my issue)
Return keystroke

Shift-D keystroke
pause .2 sec (as above)
Return keystroke
2 keystroke
pause .2
Return keystroke

Some of the time these work fine, but usually when I then select the next object I am working on, it becomes ‘shift-selected’, or multi-selected as if the Shift-key is being held down, which ruins the macro workflow. If I manually hit the shift-key on it’s own in between actions, this seems to prevent this.

In any case it seems that KM is not releasing the shift key after executing the macro for some reason.

I’m on 10.9.5 btw.

Hope someone can help with this. A bit discouraging for my first use of the programme.


Most likely this is actually Blender getting itself confused as I’ve never had any similar reports in any other context.

Other than reporting it as a bug to Blender, I don’t really have any good solutions to suggest. If the trigger itself includes a shift keystroke, you might like to add a Pause Until Modifier Shift Key is off to the start of the macro, its possible that would help Blender keep from getting confused.

But otherwise, simulating a Shift S consists of sending this sequence of events:

  • Press the Shift Key
  • Press the S Key with Shift flag set
  • Release the S with Shift flag set
  • Release the Shift Key

The sequence is always followed, and text events are always processed in sequence, so the only thing I can imagine is that Blender is tracking the shift key status somehow and missing an event.

Hey Stephen,

I don't use Blender, so I can't test. Allow me to conjecture a bit though.

Blender is definitely doing a few unconventional things with the Mac UI.

I'd play around with the keystrokes a bit:

Shift-S keystroke
pause 0.1
'4' keystroke
pause 0.1
Return keystroke
Escape or Shift-Escape or Cmd-. or a key-combination that does nothing in Blender. (Attempting to reset Blender's keyboard stack. Get creative.)


Thanks Chris and Peter for the responses. I had tried restarting and reloading on the day to see if that fixed the problem to no avail, but I’m retesting this today, and the issue hasn’t surfaced at all. So hooray, I’ll just put it down to one of those peculiar things and keep trying things out.

I’m definitely finding KM quick and intuitive to learn and use (having used Quickeys in the past, and looking for a current alternative). I’ll start getting some change together soon :smile: