%ShortTime% is inserting a funny character after I upgraded to macOS Sonoma

I have a text expander that is triggered when I type nnow, typing %ShortDate% %ShortTime%. It is now being replaced with an invisible unicode character instead of a space. The typed expansion looks like this in a text editor:

January 5, 2024 8:37<0x202f>PM

How to resolve this issue? I will replace the action with an AppleScript or a bash script for now.


Which editor did you try this in and is there a setting enabled that shows the unicode characters.
I'm on Sonoma 14.2.1 and I have no issue with BBEdit, TextEdit and Pages.


Test Time.kmmacros (1.6 KB)


Hex e2 80 af – see under unicode Narrow No-Break Space (NNBSP).


Testing here (Sonoma 14.2.1) after switching off
System Settings > General > Date & Time > 24-hour time

ShortTime test.kmmacros (1.9 KB)

1 Like

I'm using Sublime Text and I am on the same version of Sonoma 14.2.1.

I tried toggling the 24H and I can confirm that the issue is only present on the 12 hour format like because of an "intended" Narrow No-Break Space.

Thank you for looking into this. I've replaced my implementation with a custom AppleScript for now.

All Spaces that exist in the present universe are invisible Unicode chars :wink:

A good editor in many ways, but one of the things it doesn't consistently aim for is a high level of Unicode-compliance.

See, for example: RTL - support for right to left languages like Hebrew and Arabic - Technical Support - Sublime Forum

May I ask what software you use to record GIFs? Thank you!

Sure. I use ScreenFlow. You're welcome.


1 Like