Simple Macro Fails in Scrivener

There are several multi-key shortcuts in Scrivener that I want to assign to single keystrokes on keys I never use. I defined three of them, and only one of them works.

When the other two are activated, Scrivener types the character for the key I pressed. It's not like the macro is malfunctioning, it's like KM isn't even using the key as a trigger.

EDIT: it doesn't matter what key I assign, KM won't fire them. I've tried making new macros, too, but no joy. I've also restarted the KM Engine and Editor but no change. I tried using the Stream Deck's software and that worked -- but I want to trigger from the keyboard, not the SD.

Suggestions? Thanks.

Hey @anamorph,

You need to provide more information about what keyboard shortcuts and an example macro that demonstrates the problem.

-Chris

Sure.

There are three keyboard shortcuts in Scrivener that I want to trigger with a preceding return using a single key.

This one works fine:

This one fails, but without error, and it displays the trigger key:

So it appears that KM isn't even trapping the trigger key. The other shortcut fails in exactly the same way.

I've looked for trigger conflicts, restarted the Editor and Engine, restarted the Mac. No joy.

Your suggestions appreciated.

You mean trigger key is typed into Scrivener?

I tried both of these, and they each work fine with Scrivener 3.0 on macOS 10.12.6.

I suggest you recreate the non-working macros with the following actions and make sure the hotkeys can be made to work.

These actions will be installed into the macro currently being edited:

Keyboard Maestro Actions.kmactions (1.3 KB)

Let me know if you can/can't get the hotkeys themselves to fire.

-Chris

Exactly.

I tried it again today, same document, same macros, and now it's working. And I have no idea why it is behaving differently.

Thanks for your help.