Simple macro supposedly triggered, but no actions performed

New user of KM here. I'm having trouble getting a very simple macro to work and I think I'm missing something obvious.

The intent of the macro:
(I position the cursor where I want to determine a latitude and longitude)
• right click on a location in Google Maps,
• grab the latitude and longitude,
• switch windows to Google Sheets
• paste the info into a cell
• move down to next cell
• switch to Maps window
(and repeat 100x, hence the macro :blush: )

When I trigger the macro, there is no visible indication anything happened. Certainly not the intended data entry in the spreadsheet. Interactive Help in KM tells me everything worked properly and sent me here.

The macro is enabled, I have granted permissions in Privacy & Security settings (toggled a couple of times), and restarted. Tried messing with Restore Mouse Location, didn't seem relevant but didn't make any difference.

I'm thinking (hoping) I'm missing something easy and obvious. Help is appreciated.

System info:
Keyboard Maestro Version 10.2
MacOS Ventura 13.5.1 (22G90)

send lat long to sheets.kmmacros (5.2 KB)

Howdy, welcome to the forum! As you might have already figured out, this is a great community full of people who love to help. Also, thanks for posting the actual macro. That is very helpful when somebody needs help debugging issues.

If there is no visible indication anything is happening, especially with the kind of macro this is, then it sounds like it’s not actually being triggered.

I’ve made a couple of adjustments to your macro in my version below. The first action is an alert which will help you see if the macro has even started or not. After that, debugging is started which will allow you to execute each action, one at a time. Try running this version and report back what happens.

Download Macro(s): send lat long to sheets.kmmacros (32 KB)


  • Macros are always disabled when imported into the Keyboard Maestro Editor.
    • The user must ensure the macro is enabled.
    • The user must also ensure the macro's parent macro-group is enabled.
System Information
  • macOS 13.5.1
  • Keyboard Maestro v10.2

Thanks for the quick reply!

The macro triggered, and the debug window appeared. I am not sure what to do with it, however. Is it showing an action that has already happened, or the next action if I hit the "play" button? To do that, I need to move the mouse, which would take it away from the location I need it to be for the sequence.

Addendum to this, to resolve my initial mouse click problem, I just changed the first mouse click to an absolute position and hit the run button (I think) in the debugger. The debugger seemed to go through the actions in the macro, but again, no visible effect - no contextual menu pop up, no change of windows, no data pasted.

The debugger window shows the next step in the process.

You likely need a pause between each of those actions... I’m assuming you’re doing this in a browser? Try the following... adding a long pause between each action, or better yet, use the Set Action Delay action to do the same thing. Try pausing for 1 second or longer and see what happens with that.

The task I needed the macro for is done... I ended up going for something simple in Better Touch Tool.

There still remains the problem of KM not performing... I decided to make things a simple as possible and try a macro that is triggered by ⌃⌥⇧⌘7. The macro performs one keystroke action, ⌘L to select the Address field in the browser. - Nothing happens.

I tried just simulating the keystroke "S" in Notes, didn't work.

So it's not a timing thing, or a browser thing. KM just isn't running macros. It thinks it is, according to the Interactive Help.

It doesn’t sound like it isn’t “running” macros, since your earlier example did trigger the notification and debugging. It rather sounds like certain actions are not executing properly. But either way, something fishy is going on.

You mentioned earlier that you toggled privacy and security settings... did you do that for just Keyboard Maestro itself, or did you do it for Keyboard Maestro Engine as well? See Accessibility Permission Problem in the KM Wiki for more info.

Yup, toggled them both.
But your suggestion to look at the Accessibility Permission Problem doc led me to delete all the settings for KM and then run KM to reenable them. Tried my simple little macro, and it worked. :+1:t2:
Thanks for the help :blush:

1 Like

Awesome! Glad you got it going! Don’t hesitate to reach out if you need more help. :smiley:


1 Like